about summary refs log tree commit diff stats
path: root/system/users/default.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-11 12:07:32 +0100
committerene <ene@sils.li>2023-02-11 12:10:44 +0100
commitf7634949fa4e744cd5a930505ac4e9b4f81dc530 (patch)
tree7a290ad625f47430d40facaceb4f5c0706058eb8 /system/users/default.nix
parentFeat(home-manager): Add firefox config (diff)
downloadnixos-config-f7634949fa4e744cd5a930505ac4e9b4f81dc530.zip
Feat: Switch to default.nix
Diffstat (limited to 'system/users/default.nix')
-rw-r--r--system/users/default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/system/users/default.nix b/system/users/default.nix
new file mode 100644
index 00000000..2c962c26
--- /dev/null
+++ b/system/users/default.nix
@@ -0,0 +1,17 @@
+{
+  config,
+  pkgs,
+  ...
+}: {
+  users = {
+    mutableUsers = false;
+    users.soispha = {
+      isNormalUser = true;
+      home = "/srv/home/soispha";
+      shell = pkgs.zsh;
+      initialHashedPassword = "$y$jFT$ONrCqZIJKB7engmfA4orD/$0GO58/wV5wrYWj0cyONhyujZPjFmbT0XKtx2AvXLG0B";
+      extraGroups = ["wheel"];
+      uid = 1000;
+    };
+  };
+}