about summary refs log tree commit diff stats
path: root/system/disks/hibernate.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-07-11 19:18:34 +0200
committerSoispha <soispha@vhack.eu>2023-07-11 20:49:16 +0200
commit22333b9f27aa26ebafed1b8230d5e75edcf495a4 (patch)
treec9c4d276a5f4b3126c849bbfd8b02528db4aa6ac /system/disks/hibernate.nix
parentFix(hm/conf/ssh): Only connect to codeberg.org over ipv4 (ipv6 failed) (diff)
downloadnixos-config-22333b9f27aa26ebafed1b8230d5e75edcf495a4.zip
Fix(system/disks/hibernate): Try to activate it
Diffstat (limited to 'system/disks/hibernate.nix')
-rw-r--r--system/disks/hibernate.nix26
1 files changed, 13 insertions, 13 deletions
diff --git a/system/disks/hibernate.nix b/system/disks/hibernate.nix
index 26dd223a..e6d989f2 100644
--- a/system/disks/hibernate.nix
+++ b/system/disks/hibernate.nix
@@ -10,11 +10,11 @@
       serviceConfig = {
         Type = "oneshot";
         User = "root";
-        ExecStart = "${pkgs.dash}/bin/dash -c \"${pkgs.util-linux}/bin/swapon /swap/swapfile && ${pkgs.util-linux}/bin/swapoff /dev/zram0\"";
+        ExecStart = "${pkgs.bash}/bin/bash -c \"${pkgs.util-linux}/bin/swapon /swap/swapfile && ${pkgs.util-linux}/bin/swapoff /dev/zram0\"";
       };
     };
     hibernate-resume = {
-      wantedBy = ["hibernate.target"];
+      wantedBy = ["systemd-hibernate.service"];
       unitConfig = {
         Description = "Disable swap after resuming from hibernation";
         After = "hibernate.target";
@@ -25,17 +25,17 @@
         ExecStart = "${pkgs.util-linux}/bin/swapoff /swap/swapfile";
       };
     };
-    swapoff-start = {
-      wantedBy = ["multi-user.target"];
-      unitConfig = {
-        Description = "Disable hardware swap after booting";
-      };
-      serviceConfig = {
-        Type = "oneshot";
-        User = "root";
-        ExecStart = "${pkgs.util-linux}/bin/swapoff /swap/swapfile";
-      };
-    };
+    # swapoff-start = {
+    #      wantedBy = ["multi-user.target"];
+    #      unitConfig = {
+    #        Description = "Disable hardware swap after booting";
+    #      };
+    #      serviceConfig = {
+    #        Type = "oneshot";
+    #        User = "root";
+    #        ExecStart = "${pkgs.util-linux}/bin/swapoff /swap/swapfile";
+    #      };
+    #    };
     systemd-hibernate.serviceConfig.Environment = "SYSTEMD_BYPASS_HIBERNATION_MEMORY_CHECK=1";
     systemd-logind.serviceConfig.Environment = "SYSTEMD_BYPASS_HIBERNATION_MEMORY_CHECK=1";
   };