about summary refs log tree commit diff stats
path: root/system/default.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-19 21:31:37 +0100
committerene <ene@sils.li>2023-02-19 21:31:37 +0100
commit0412e046d917f0d559ed893513373682b2c049e2 (patch)
tree67645f8142505e499199d4be87436c2d355baf6d /system/default.nix
parentFeat(lf): Add dependencies for the shell scripts (diff)
downloadnixos-config-0412e046d917f0d559ed893513373682b2c049e2.zip
Feat(lib): Import my system library
Diffstat (limited to 'system/default.nix')
-rw-r--r--system/default.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/system/default.nix b/system/default.nix
index 14762c92..e065bfc9 100644
--- a/system/default.nix
+++ b/system/default.nix
@@ -1,4 +1,9 @@
-{config, ...}: {
+{
+  config,
+  pkgs,
+  shell-library,
+  ...
+}: {
   imports = [
     ./boot
     ./users # this needs to be before fileSystemLayouts
@@ -6,7 +11,7 @@
     ./font
     ./impermanence
     ./locale
-#./packages
+    #./packages
     ./sound
   ];
 }