about summary refs log tree commit diff stats
path: root/sys/svcs/nix/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
committerSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
commit3f600ab07dbad3b6dd7655587ddea158b19aea71 (patch)
tree7164ccd965e1d14ade970aeb8eb188b1442a6c91 /sys/svcs/nix/default.nix
parentStyle(treewide): Format all lua-files makes lua ➛ nix easier (diff)
downloadnixos-config-3f600ab07dbad3b6dd7655587ddea158b19aea71.zip
Refactor(treewide): Abbreviate path names
Diffstat (limited to 'sys/svcs/nix/default.nix')
-rw-r--r--sys/svcs/nix/default.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys/svcs/nix/default.nix b/sys/svcs/nix/default.nix
new file mode 100644
index 00000000..97b7220d
--- /dev/null
+++ b/sys/svcs/nix/default.nix
@@ -0,0 +1,39 @@
+{
+  pkgs,
+  nixpkgs_as_input,
+  templates,
+  ...
+}: let
+  nixpkgs = nixpkgs_as_input;
+in {
+  nix = {
+    package = pkgs.nixStable;
+
+    registry = {
+      nixpkgs.flake = nixpkgs;
+      n.flake = nixpkgs;
+      t.flake = templates;
+    };
+
+    gc = {
+      automatic = true;
+      dates = "weekly";
+      options = "--delete-older-than 7d";
+    };
+    settings = {
+      auto-optimise-store = true;
+      experimental-features = [
+        "nix-command"
+        "flakes"
+        #"ca-derivations"
+      ];
+
+      #substituters = ["https://cache.ngi0.nixos.org/"];
+      #trusted-public-keys = ["cache.ngi0.nixos.org-1:KqH5CBLNSyX184S9BKZJo1LxrxJ9ltnY2uAs5c/f1MA="];
+      fallback = true; # TODO: what does this do?
+
+      keep-failed = true; # keep failed tmp build dirs
+      pure-eval = true; # restrict file system and network access to hash
+    };
+  };
+}