about summary refs log tree commit diff stats
path: root/sys/disks/fstrim.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-20 16:10:21 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-20 16:14:26 +0200
commit368cb6b0d25db2ae23be42ad51584de059997e51 (patch)
tree3282e45d3ebced63c8498a47e83a255c35de620b /sys/disks/fstrim.nix
parentrefactor(hm): Rename to `modules/home` (diff)
downloadnixos-config-368cb6b0d25db2ae23be42ad51584de059997e51.zip
refactor(sys): Modularize and move to `modules/system` or `pkgs`
Diffstat (limited to 'sys/disks/fstrim.nix')
-rw-r--r--sys/disks/fstrim.nix42
1 files changed, 0 insertions, 42 deletions
diff --git a/sys/disks/fstrim.nix b/sys/disks/fstrim.nix
deleted file mode 100644
index 6daeb65e..00000000
--- a/sys/disks/fstrim.nix
+++ /dev/null
@@ -1,42 +0,0 @@
-{
-  pkgs,
-  lib,
-  cfg,
-}: {
-  timers.fstrim = lib.mkIf cfg.ssd {
-    wantedBy = ["timers.target"];
-    wants = ["fstrim.service"];
-    unitConfig = {
-      Description = "Discard unused blocks once a week";
-      Documentation = "man:fstrim";
-      ConditionVirtualization = "!container";
-      ConditionPathExists = "!/etc/initrd-release";
-    };
-    timerConfig = {
-      OnCalendar = "weekly";
-      AccuracySec = "1h";
-      Persistent = "true";
-      RandomizedDelaySec = "6000";
-    };
-  };
-  services.fstrim = lib.mkIf cfg.ssd {
-    wantedBy = lib.mkForce [];
-    unitConfig = {
-      Description = "Discard unused blocks on filesystems from /etc/fstab";
-      Documentation = "man:fstrim(8)";
-      ConditionVirtualization = "!container";
-    };
-    serviceConfig = {
-      Type = "oneshot";
-      ExecStart = "${pkgs.util-linux}/bin/fstrim --listed-in /etc/fstab:/proc/self/mountinfo --verbose --quiet-unsupported";
-      PrivateDevices = "no";
-      PrivateNetwork = "yes";
-      PrivateUsers = "no";
-      ProtectKernelTunables = "yes";
-      ProtectKernelModules = "yes";
-      ProtectControlGroups = "yes";
-      MemoryDenyWriteExecute = "yes";
-      SystemCallFilter = "@default @file-system @basic-io @system-service";
-    };
-  };
-}