about summary refs log tree commit diff stats
path: root/modules/system/home-manager/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
commitc52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c (patch)
treee8b947710b467b32740598ff574982097836f66c /modules/system/home-manager/default.nix
parentchore(pkgs/yt): 1.2.1 -> 1.3.0 (diff)
downloadnixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.zip
refactor(modules): Move all system modules to `by-name`
From now on all modules should be added to the new `by-name` directory.
This should help remove the (superficial and utterly useless)
distinction between `home-manager` and `NixOS` modules.
Diffstat (limited to 'modules/system/home-manager/default.nix')
-rw-r--r--modules/system/home-manager/default.nix56
1 files changed, 0 insertions, 56 deletions
diff --git a/modules/system/home-manager/default.nix b/modules/system/home-manager/default.nix
deleted file mode 100644
index 096aaceb..00000000
--- a/modules/system/home-manager/default.nix
+++ /dev/null
@@ -1,56 +0,0 @@
-{
-  config,
-  lib,
-  pkgsStable,
-  nixpkgs_open_prs,
-  sysLib,
-  # extra information
-  system,
-  # bins
-  # TODO: Integrate these <2024-05-22>
-  river_init_lesser,
-  shell_library,
-  # external deps
-  user_js,
-  # modules
-  impermanence,
-  nix-index-database,
-  nixVim,
-  ...
-}: let
-  cfg = config.soispha.home-manager;
-in {
-  options.soispha.home-manager = {
-    enable = lib.mkEnableOption "home-manager with custom config.";
-  };
-
-  config = lib.mkIf cfg.enable {
-    home-manager = {
-      useGlobalPkgs = true;
-      useUserPackages = true;
-      users.soispha = import ../../home;
-      extraSpecialArgs = {
-        inherit
-          nixpkgs_open_prs
-          pkgsStable
-          sysLib
-          # extra information
-          
-          system
-          # bins
-          
-          river_init_lesser
-          shell_library
-          # external deps
-          
-          user_js
-          # modules
-          
-          impermanence
-          nixVim
-          nix-index-database
-          ;
-      };
-    };
-  };
-}