about summary refs log tree commit diff stats
path: root/modules/home/soispha/conf/firefox/config/bookmarks/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-20 16:06:57 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-20 16:14:24 +0200
commit5156e1aae36a153be98b6832ab3ced7be2b2faee (patch)
tree3f050d3bc567af4c72f87e0925d21c3521436e45 /modules/home/soispha/conf/firefox/config/bookmarks/default.nix
parentrefactor(hm/conf/zsh): Remove old zsh-prompt file (diff)
downloadnixos-config-5156e1aae36a153be98b6832ab3ced7be2b2faee.zip
refactor(hm): Rename to `modules/home`
Diffstat (limited to 'modules/home/soispha/conf/firefox/config/bookmarks/default.nix')
-rw-r--r--modules/home/soispha/conf/firefox/config/bookmarks/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/modules/home/soispha/conf/firefox/config/bookmarks/default.nix b/modules/home/soispha/conf/firefox/config/bookmarks/default.nix
new file mode 100644
index 00000000..c612bf4d
--- /dev/null
+++ b/modules/home/soispha/conf/firefox/config/bookmarks/default.nix
@@ -0,0 +1,31 @@
+{
+  lib,
+  pkgs,
+  ...
+}: let
+  bookmarks = [
+    {
+      name = "Feed - Piped";
+      url = "https://piped.video/feed";
+    }
+
+    {
+      name = "DeepL Translate";
+      url = "https://www.deepl.com/translator";
+    }
+
+    {
+      name = "Nix lib";
+      url = "https://teu5us.github.io/nix-lib.html";
+    }
+
+    {
+      name = "Nixpkgs manual";
+      url = "https://ryantm.github.io/nixpkgs/";
+    }
+  ];
+
+  mkBookmarksFile = (import ./lib.nix) {inherit lib pkgs;};
+  bookmarks_file = mkBookmarksFile bookmarks;
+in
+  bookmarks_file