about summary refs log tree commit diff stats
path: root/modules/home/soispha/conf/alacritty/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-20 16:06:57 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-20 16:14:24 +0200
commit5156e1aae36a153be98b6832ab3ced7be2b2faee (patch)
tree3f050d3bc567af4c72f87e0925d21c3521436e45 /modules/home/soispha/conf/alacritty/default.nix
parentrefactor(hm/conf/zsh): Remove old zsh-prompt file (diff)
downloadnixos-config-5156e1aae36a153be98b6832ab3ced7be2b2faee.zip
refactor(hm): Rename to `modules/home`
Diffstat (limited to 'modules/home/soispha/conf/alacritty/default.nix')
-rw-r--r--modules/home/soispha/conf/alacritty/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/modules/home/soispha/conf/alacritty/default.nix b/modules/home/soispha/conf/alacritty/default.nix
new file mode 100644
index 00000000..c1cf5e44
--- /dev/null
+++ b/modules/home/soispha/conf/alacritty/default.nix
@@ -0,0 +1,30 @@
+{lib, ...}: let
+  config_file = ''
+    ${lib.strings.fileContents ./toml/base.toml}
+    ${lib.strings.fileContents ./toml/bell.toml}
+    ${lib.strings.fileContents ./toml/colorscheme.toml}
+    ${lib.strings.fileContents ./toml/cursor.toml}
+    ${lib.strings.fileContents ./toml/env.toml}
+    ${lib.strings.fileContents ./toml/font.toml}
+    ${lib.strings.fileContents ./toml/hints.toml}
+    ${lib.strings.fileContents ./toml/keyboard_bindings.toml}
+    ${lib.strings.fileContents ./toml/mouse.toml}
+    ${lib.strings.fileContents ./toml/mouse_bindings.toml}
+    ${lib.strings.fileContents ./toml/scrolling.toml}
+    ${lib.strings.fileContents ./toml/selection.toml}
+    ${lib.strings.fileContents ./toml/window.toml}
+  '';
+in {
+  home.sessionVariables = {
+    # This is **not** the TERM variable but a special one to signify my favorite terminal.
+    TERMINAL = "alacritty";
+
+    # These two here should be set by alacritty at start-up
+    # TERM = "alacritty";
+    # COLORTERM = "truecolor";
+  };
+  programs.alacritty = {
+    enable = true;
+  };
+  xdg.configFile."alacritty/alacritty.toml".text = config_file;
+}