about summary refs log tree commit diff stats
path: root/modules/home/files/manifest_json/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:31:11 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:33:40 +0200
commitfd9b0ecef4142a62b45404700ba1cff488f84a73 (patch)
treeef6c1f74f05a2220a41ccff4b0890c39229f32f7 /modules/home/files/manifest_json/default.nix
parentrefactor(pkgs): Categorize into `by-name` shards (diff)
downloadnixos-config-fd9b0ecef4142a62b45404700ba1cff488f84a73.zip
refactor(modules/home): Setup as "normal" NixOS module
Diffstat (limited to 'modules/home/files/manifest_json/default.nix')
-rw-r--r--modules/home/files/manifest_json/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/modules/home/files/manifest_json/default.nix b/modules/home/files/manifest_json/default.nix
new file mode 100644
index 00000000..af8d85d2
--- /dev/null
+++ b/modules/home/files/manifest_json/default.nix
@@ -0,0 +1,16 @@
+{
+  config,
+  lib,
+  ...
+}: {
+  home = {
+    activation = {
+      addManifestJson =
+        lib.hm.dag.entryAfter ["writeBoundary"]
+        ''
+          [ -L "${config.xdg.stateHome}/nix/profiles/profile" ] && $DRY_RUN_CMD rm $VERBOSE_ARG "${config.xdg.stateHome}/nix/profiles/profile"
+          $DRY_RUN_CMD ln -s $DRY_RUN_CMD "${./profile}" "${config.xdg.stateHome}/nix/profiles/profile"
+        '';
+    };
+  };
+}