about summary refs log tree commit diff stats
path: root/modules/home/conf/timewarrior/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:31:11 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:33:40 +0200
commitfd9b0ecef4142a62b45404700ba1cff488f84a73 (patch)
treeef6c1f74f05a2220a41ccff4b0890c39229f32f7 /modules/home/conf/timewarrior/default.nix
parentrefactor(pkgs): Categorize into `by-name` shards (diff)
downloadnixos-config-fd9b0ecef4142a62b45404700ba1cff488f84a73.zip
refactor(modules/home): Setup as "normal" NixOS module
Diffstat (limited to 'modules/home/conf/timewarrior/default.nix')
-rw-r--r--modules/home/conf/timewarrior/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/modules/home/conf/timewarrior/default.nix b/modules/home/conf/timewarrior/default.nix
new file mode 100644
index 00000000..bcb627f5
--- /dev/null
+++ b/modules/home/conf/timewarrior/default.nix
@@ -0,0 +1,22 @@
+{pkgs, ...}: {
+  home.packages = [
+    pkgs.timewarrior
+  ];
+  xdg.configFile."timewarrior/timewarrior.cfg".text = ''
+    # source: https://github.com/arcticicestudio/igloo
+    #+----+
+    #+ UI +
+    #+----+
+    import ${./nord.theme}
+    color = true
+
+    #+---------+
+    #+ Reports +
+    #+---------+
+    define reports:
+      day:
+        lines = 10
+        month = true
+        week = true
+  '';
+}