about summary refs log tree commit diff stats
path: root/modules/home/conf/nvim/plgs/comment-nvim/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:31:11 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:33:40 +0200
commitfd9b0ecef4142a62b45404700ba1cff488f84a73 (patch)
treeef6c1f74f05a2220a41ccff4b0890c39229f32f7 /modules/home/conf/nvim/plgs/comment-nvim/default.nix
parentrefactor(pkgs): Categorize into `by-name` shards (diff)
downloadnixos-config-fd9b0ecef4142a62b45404700ba1cff488f84a73.zip
refactor(modules/home): Setup as "normal" NixOS module
Diffstat (limited to 'modules/home/conf/nvim/plgs/comment-nvim/default.nix')
-rw-r--r--modules/home/conf/nvim/plgs/comment-nvim/default.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/modules/home/conf/nvim/plgs/comment-nvim/default.nix b/modules/home/conf/nvim/plgs/comment-nvim/default.nix
new file mode 100644
index 00000000..2a73b8db
--- /dev/null
+++ b/modules/home/conf/nvim/plgs/comment-nvim/default.nix
@@ -0,0 +1,41 @@
+{...}: {
+  programs.nixvim = {
+    plugins.comment = {
+      enable = true;
+      settings = {
+        padding = true;
+        sticky = true;
+        mappings = {
+          basic = false;
+          extra = false;
+        };
+      };
+    };
+    keymaps = [
+      {
+        key = "gcc";
+        mode = "v";
+        action = "<Plug>(comment_toggle_linewise_visual)";
+        options.desc = "toggle the current line in a linewise comment";
+      }
+      {
+        key = "gbc";
+        mode = "v";
+        action = "<Plug>(comment_toggle_blockwise_visual)";
+        options.desc = "toggle the current line in a blockwise comment";
+      }
+      {
+        key = "gcc";
+        mode = "n";
+        action = "<Plug>(comment_toggle_linewise_current)";
+        options.desc = "toggle the current line in a linewise comment";
+      }
+      {
+        key = "gbc";
+        mode = "n";
+        action = "<Plug>(comment_toggle_blockwise_current)";
+        options.desc = "toggle the current line in a blockwise comment";
+      }
+    ];
+  };
+}