about summary refs log tree commit diff stats
path: root/modules/home/conf/firefox/scripts/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
commitc52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c (patch)
treee8b947710b467b32740598ff574982097836f66c /modules/home/conf/firefox/scripts/default.nix
parentchore(pkgs/yt): 1.2.1 -> 1.3.0 (diff)
downloadnixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.zip
refactor(modules): Move all system modules to `by-name`
From now on all modules should be added to the new `by-name` directory.
This should help remove the (superficial and utterly useless)
distinction between `home-manager` and `NixOS` modules.
Diffstat (limited to 'modules/home/conf/firefox/scripts/default.nix')
-rw-r--r--modules/home/conf/firefox/scripts/default.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/modules/home/conf/firefox/scripts/default.nix b/modules/home/conf/firefox/scripts/default.nix
deleted file mode 100644
index 1127662b..00000000
--- a/modules/home/conf/firefox/scripts/default.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-{
-  pkgs,
-  sysLib,
-  ...
-}: let
-  unzip_mozlz4 = pkgs.stdenv.mkDerivation {
-    name = "unzip_mozlz4";
-    propagatedBuildInputs = [
-      (pkgs.python3.withPackages (pythonPackages:
-        with pythonPackages; [
-          lz4
-        ]))
-    ];
-    dontUnpack = true;
-    installPhase = "install -Dm755 ${./unzip_mozlz4.py} $out/bin/unzip_mozlz4";
-  };
-  extract_cookies = sysLib.writeShellScript {
-    name = "extract_cookies";
-    src = ./extract_cookies.sh;
-    dependencies = with pkgs; [
-      bash
-      sqlite
-      mktemp
-      coreutils
-    ];
-  };
-in {
-  inherit unzip_mozlz4 extract_cookies;
-}