about summary refs log tree commit diff stats
path: root/modules/home/conf/alacritty/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:31:11 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:33:40 +0200
commitfd9b0ecef4142a62b45404700ba1cff488f84a73 (patch)
treeef6c1f74f05a2220a41ccff4b0890c39229f32f7 /modules/home/conf/alacritty/default.nix
parentrefactor(pkgs): Categorize into `by-name` shards (diff)
downloadnixos-config-fd9b0ecef4142a62b45404700ba1cff488f84a73.zip
refactor(modules/home): Setup as "normal" NixOS module
Diffstat (limited to 'modules/home/conf/alacritty/default.nix')
-rw-r--r--modules/home/conf/alacritty/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/modules/home/conf/alacritty/default.nix b/modules/home/conf/alacritty/default.nix
new file mode 100644
index 00000000..c1cf5e44
--- /dev/null
+++ b/modules/home/conf/alacritty/default.nix
@@ -0,0 +1,30 @@
+{lib, ...}: let
+  config_file = ''
+    ${lib.strings.fileContents ./toml/base.toml}
+    ${lib.strings.fileContents ./toml/bell.toml}
+    ${lib.strings.fileContents ./toml/colorscheme.toml}
+    ${lib.strings.fileContents ./toml/cursor.toml}
+    ${lib.strings.fileContents ./toml/env.toml}
+    ${lib.strings.fileContents ./toml/font.toml}
+    ${lib.strings.fileContents ./toml/hints.toml}
+    ${lib.strings.fileContents ./toml/keyboard_bindings.toml}
+    ${lib.strings.fileContents ./toml/mouse.toml}
+    ${lib.strings.fileContents ./toml/mouse_bindings.toml}
+    ${lib.strings.fileContents ./toml/scrolling.toml}
+    ${lib.strings.fileContents ./toml/selection.toml}
+    ${lib.strings.fileContents ./toml/window.toml}
+  '';
+in {
+  home.sessionVariables = {
+    # This is **not** the TERM variable but a special one to signify my favorite terminal.
+    TERMINAL = "alacritty";
+
+    # These two here should be set by alacritty at start-up
+    # TERM = "alacritty";
+    # COLORTERM = "truecolor";
+  };
+  programs.alacritty = {
+    enable = true;
+  };
+  xdg.configFile."alacritty/alacritty.toml".text = config_file;
+}