about summary refs log tree commit diff stats
path: root/modules/home.legacy/pkgs/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-04-04 16:27:33 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-04-04 16:27:33 +0200
commit8b1f5e70b9aa86da8e3e1e6c8e1472480a23b7de (patch)
treee80cdcc1bb9352e1af52e7cc6f441f0630872e01 /modules/home.legacy/pkgs/default.nix
parentfix(modules/nix): Don't keep failed build directories (diff)
downloadnixos-config-8b1f5e70b9aa86da8e3e1e6c8e1472480a23b7de.zip
refactor(modules/legacy/pkgs): Remove rarely used packages
I can (and often already do) use them via `nix shell n#<pkgs>`, so
having them always available seems unnecessary.
Diffstat (limited to 'modules/home.legacy/pkgs/default.nix')
-rw-r--r--modules/home.legacy/pkgs/default.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/modules/home.legacy/pkgs/default.nix b/modules/home.legacy/pkgs/default.nix
index e9181b99..31942f0d 100644
--- a/modules/home.legacy/pkgs/default.nix
+++ b/modules/home.legacy/pkgs/default.nix
@@ -11,21 +11,12 @@ with pkgs; let
       alacritty # default terminal
     ];
 
-    Social = [
-      signal-desktop # to avoid encryption problems with signal-bridge
-    ];
-
     Misc = [
       keepassxc # password manager
-      anki-bin # spaced repetition
     ];
   };
 
   TuiCli = {
-    EyeCandy = [
-      hyfetch # Neofetch with LGBTQ pride flags.
-    ];
-
     Social = [
       iamb # best tui matrix client (as of today)
     ];
@@ -35,9 +26,6 @@ with pkgs; let
     ];
 
     Misc = [
-      android-file-transfer # Android MTP client with minimalistic UI
-      #xdg-ninja # A shell script which checks your $HOME for unwanted files and directories.
-      xdg-utils # open urls and such things
       killall # kill a application by name
       snap-sync-forked # A btrfs based backup solution
       bc # Smart calculator
@@ -60,26 +48,18 @@ with pkgs; let
 
     WM = {
       CLITools = [
-        lswt # List Wayland toplevels.
         wl-clipboard # Command-line copy/paste utilities.
       ];
-
-      Media = [
-        libnotify # a command to send a notification.
-      ];
     };
 
     Media = {
       View = [
-        imv # Image viewer
         zathura # PDF viewer
       ];
 
       YouTube = [
         yt # A command line YouTube client
       ];
-
-      Listen = [];
     };
 
     Hardware = {
@@ -112,19 +92,11 @@ with pkgs; let
       tree # A directory listing program displaying a depth indented list of files
       fd # Simple, fast and user-friendly alternative to find
       ripgrep # A search tool that combines the usability of ag with the raw speed of grep
-      fzf # used to quickly move around with its keybindings
       file # Show information about a file
       ll # Wrapper around `lf` to automatically change the path
       lm # Wrapper around `ll` to automatically cd to the last accessed path
     ];
 
-    Editors = [
-      ed # A POSIX-compliant line-oriented text editor
-      #sed # GNU stream editor
-      vim # The original ex/vi text editor (this is `vim` and not `vi`, as `vi` is unfree)
-      #neovim # Fork of Vim aiming to improve user experience, plugins, and GUIs
-    ];
-
     Programming = {
       GeneralTools = [
         stamp # Add a license header to a file
@@ -135,8 +107,6 @@ with pkgs; let
       ];
     };
   };
-  # TODO: unmaintained, find sth else:
-  # handlr # Powerful alternative to xdg-utils written in Rust
   mapFun = x:
     if builtins.isAttrs x
     then