about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/yambar/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-11-29 18:51:52 +0100
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-11-29 19:37:38 +0100
commit2138b4624eae088a81852f50b3a8f50fc0431a10 (patch)
tree701f7fdd68775c4c1589db463ef4ed37458c354c /modules/home.legacy/conf/yambar/default.nix
parentchore(pkgs/by-name/ya/{cpu,memory}): Merge (diff)
downloadnixos-config-2138b4624eae088a81852f50b3a8f50fc0431a10.zip
refactor(modules/legacy/conf/yambar): Move to `by-name` and modernize
Diffstat (limited to 'modules/home.legacy/conf/yambar/default.nix')
-rw-r--r--modules/home.legacy/conf/yambar/default.nix50
1 files changed, 0 insertions, 50 deletions
diff --git a/modules/home.legacy/conf/yambar/default.nix b/modules/home.legacy/conf/yambar/default.nix
deleted file mode 100644
index 72dcaa8e..00000000
--- a/modules/home.legacy/conf/yambar/default.nix
+++ /dev/null
@@ -1,50 +0,0 @@
-{
-  nixosConfig,
-  sysLib,
-  pkgs,
-  lib,
-  ...
-}: let
-  makeScript = {
-    name,
-    dependencies,
-    ...
-  }:
-    sysLib.writeShellScript {
-      inherit name;
-      src = ./scripts/${name}.sh;
-      dependencies = dependencies ++ (builtins.attrValues {inherit (pkgs) dash;});
-    }
-    + "/bin/${name}";
-in {
-  xdg.configFile."yambar/config.yml".source = pkgs.substituteAll {
-    src =
-      if nixosConfig.soispha.laptop.enable
-      then ./config/laptop.yml
-      else ./config/config.yml;
-
-    backlight =
-      if nixosConfig.soispha.laptop.enable
-      then nixosConfig.soispha.laptop.backlight
-      else "";
-
-    mpd_song_name_script = makeScript {
-      dependencies = builtins.attrValues {inherit (pkgs) mpc;};
-      name = "mpd_song_name";
-    };
-
-    volume_script = makeScript {
-      dependencies = builtins.attrValues {inherit (pkgs) pulseaudio gawk coreutils;};
-      name = "sound-volume";
-    };
-
-    cpu_script = lib.getExe pkgs.yambar-cpu;
-
-    memory_script = lib.getExe pkgs.yambar-memory;
-
-    disk_script = makeScript {
-      dependencies = builtins.attrValues {inherit (pkgs) gawk btrfs-progs coreutils;};
-      name = "disk";
-    };
-  };
-}