about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/nvim/plgs/lf-nvim/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
commitc52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c (patch)
treee8b947710b467b32740598ff574982097836f66c /modules/home.legacy/conf/nvim/plgs/lf-nvim/default.nix
parentchore(pkgs/yt): 1.2.1 -> 1.3.0 (diff)
downloadnixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.zip
refactor(modules): Move all system modules to `by-name`
From now on all modules should be added to the new `by-name` directory.
This should help remove the (superficial and utterly useless)
distinction between `home-manager` and `NixOS` modules.
Diffstat (limited to 'modules/home.legacy/conf/nvim/plgs/lf-nvim/default.nix')
-rw-r--r--modules/home.legacy/conf/nvim/plgs/lf-nvim/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/modules/home.legacy/conf/nvim/plgs/lf-nvim/default.nix b/modules/home.legacy/conf/nvim/plgs/lf-nvim/default.nix
new file mode 100644
index 00000000..11ad2807
--- /dev/null
+++ b/modules/home.legacy/conf/nvim/plgs/lf-nvim/default.nix
@@ -0,0 +1,18 @@
+{
+  pkgs,
+  lib,
+  ...
+}: {
+  programs.nixvim = {
+    # TODO: package lf-nvim though a module
+    # FIXME: change the nvim path, when I change the path with lf
+    extraConfigLuaPost = ''
+      ${lib.strings.fileContents ./lua/lf-nvim.lua}
+    '';
+    extraPlugins = [
+      pkgs.vimExtraPlugins.lf-nvim
+
+      pkgs.vimPlugins.toggleterm-nvim # required by lf-nvim
+    ];
+  };
+}