about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/firefox/package.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
commitc52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c (patch)
treee8b947710b467b32740598ff574982097836f66c /modules/home.legacy/conf/firefox/package.nix
parentchore(pkgs/yt): 1.2.1 -> 1.3.0 (diff)
downloadnixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.zip
refactor(modules): Move all system modules to `by-name`
From now on all modules should be added to the new `by-name` directory.
This should help remove the (superficial and utterly useless)
distinction between `home-manager` and `NixOS` modules.
Diffstat (limited to 'modules/home.legacy/conf/firefox/package.nix')
-rw-r--r--modules/home.legacy/conf/firefox/package.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/modules/home.legacy/conf/firefox/package.nix b/modules/home.legacy/conf/firefox/package.nix
new file mode 100644
index 00000000..f7e4319b
--- /dev/null
+++ b/modules/home.legacy/conf/firefox/package.nix
@@ -0,0 +1,30 @@
+# taken from the NixOS Firefox module: https://github.com/NixOS/nixpkgs/blob/7c9cc5a6e5d38010801741ac830a3f8fd667a7a0/nixos/modules/programs/firefox.nix
+{
+  config,
+  lib,
+  pkgs,
+  # options
+  autoConfig ? "",
+  extraNativeMessagingHosts ? [],
+  wrapperConfig ? {},
+  extraPolicies ? {},
+  base_package ? pkgs.firefox,
+}: let
+  pkg = base_package.override (old: {
+    extraPrefsFiles =
+      (old.extraPrefsFiles or [])
+      ++ [
+        (pkgs.writeText "autoConfig.js" autoConfig)
+      ];
+    nativeMessagingHosts = old.nativeMessagingHosts or [] ++ extraNativeMessagingHosts;
+    cfg = (old.cfg or {}) // wrapperConfig;
+    extraPoliciesFiles =
+      (old.extraPoliciesFiles or [])
+      ++ [
+        (
+          pkgs.writeText "policies.json" (builtins.toJSON extraPolicies)
+        )
+      ];
+  });
+in
+  pkg