about summary refs log tree commit diff stats
path: root/modules/by-name/im/impermanence/module.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-05-16 16:44:30 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-05-16 16:44:30 +0200
commita76847911c1975bf89e031154c7722d7919ef053 (patch)
tree630a0d1b43a6ed7a27029f1cddb3ada0eb28263f /modules/by-name/im/impermanence/module.nix
parentflake: Pack arguments in attribute sets (diff)
downloadnixos-config-a76847911c1975bf89e031154c7722d7919ef053.zip
modules: Import external modules in the module that actually need them
Diffstat (limited to 'modules/by-name/im/impermanence/module.nix')
-rw-r--r--modules/by-name/im/impermanence/module.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/modules/by-name/im/impermanence/module.nix b/modules/by-name/im/impermanence/module.nix
index 8943cb7a..4ce86b25 100644
--- a/modules/by-name/im/impermanence/module.nix
+++ b/modules/by-name/im/impermanence/module.nix
@@ -10,6 +10,7 @@
 {
   config,
   lib,
+  modules,
   ...
 }: let
   cfg = config.soispha.impermanence;
@@ -32,6 +33,10 @@ in {
     };
   };
 
+  imports = [
+    modules.impermanence.nixosModules.impermanence
+  ];
+
   config = lib.mkIf cfg.enable {
     environment.persistence = {
       "/srv" = {