about summary refs log tree commit diff stats
path: root/modules/by-name/bo/boot/module.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-05-16 16:44:30 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-05-16 16:44:30 +0200
commita76847911c1975bf89e031154c7722d7919ef053 (patch)
tree630a0d1b43a6ed7a27029f1cddb3ada0eb28263f /modules/by-name/bo/boot/module.nix
parentflake: Pack arguments in attribute sets (diff)
downloadnixos-config-a76847911c1975bf89e031154c7722d7919ef053.zip
modules: Import external modules in the module that actually need them
Diffstat (limited to 'modules/by-name/bo/boot/module.nix')
-rw-r--r--modules/by-name/bo/boot/module.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/modules/by-name/bo/boot/module.nix b/modules/by-name/bo/boot/module.nix
index 8b9ca6dd..404352ac 100644
--- a/modules/by-name/bo/boot/module.nix
+++ b/modules/by-name/bo/boot/module.nix
@@ -11,6 +11,7 @@
   config,
   lib,
   pkgs,
+  modules,
   ...
 }: let
   cfg = config.soispha.boot;
@@ -21,6 +22,10 @@ in {
     # enableIsoEntry = lib.mkEnableOption "an tails iso boot entry";
   };
 
+  imports = [
+    modules.lanzaboote.nixosModules.lanzaboote
+  ];
+
   config = lib.mkIf cfg.enable (
     # let
     # cfg = config.boot.loader.systemd-boot;