about summary refs log tree commit diff stats
path: root/hosts/tiamat/hardware/default.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-20 01:01:13 +0100
committerene <ene@sils.li>2023-02-20 01:01:13 +0100
commit7f26288284429e2f186d7dc61de716dbd36ef8c4 (patch)
tree6c34287b0d8d2e0ce0fcbd921bfd0fecd76a477e /hosts/tiamat/hardware/default.nix
parentFix(bootstrap): Fix nasty grep bug (diff)
downloadnixos-config-7f26288284429e2f186d7dc61de716dbd36ef8c4.zip
Feat(flake): Reorder hosts
Diffstat (limited to 'hosts/tiamat/hardware/default.nix')
-rw-r--r--hosts/tiamat/hardware/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/hosts/tiamat/hardware/default.nix b/hosts/tiamat/hardware/default.nix
new file mode 100644
index 00000000..bd7241b3
--- /dev/null
+++ b/hosts/tiamat/hardware/default.nix
@@ -0,0 +1,28 @@
+{
+  config,
+  lib,
+  pkgs,
+  modulesPath,
+  ...
+}: {
+  imports = [
+    (modulesPath + "/installer/scan/not-detected.nix") # TODO is this necessary?
+    ./cpu.nix
+    ./gpu.nix
+  ];
+
+  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+
+  system.fileSystemLayouts = {
+    enable = true;
+    mainDisk = "/dev/disk/by-uuid/<uuid>";
+    efiDisk = "/dev/disk/by-uuid/<uuid>";
+  };
+
+  boot = {
+    kernelModules = ["kvm-amd"];
+
+    # TODO check this:
+    initrd.availableKernelModules = ["xhci_pci" "nvme" "rtsx_pci_sdmmc"];
+  };
+}