about summary refs log tree commit diff stats
path: root/hosts/tiamat/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-05-16 16:45:40 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-05-16 16:45:40 +0200
commit176d9bb96e8923b84bb0bdc731ef707514c0d53e (patch)
treecab831d04c6c919d41c11fe6abfe67de34c90699 /hosts/tiamat/default.nix
parentmodules: Import external modules in the module that actually need them (diff)
downloadnixos-config-176d9bb96e8923b84bb0bdc731ef707514c0d53e.zip
hosts: Move to a `by-name` schema
Diffstat (limited to 'hosts/tiamat/default.nix')
-rw-r--r--hosts/tiamat/default.nix144
1 files changed, 0 insertions, 144 deletions
diff --git a/hosts/tiamat/default.nix b/hosts/tiamat/default.nix
deleted file mode 100644
index 794b8390..00000000
--- a/hosts/tiamat/default.nix
+++ /dev/null
@@ -1,144 +0,0 @@
-# nixos-config - My current NixOS configuration
-#
-# Copyright (C) 2025 Benedikt Peetz <benedikt.peetz@b-peetz.de>
-# SPDX-License-Identifier: GPL-3.0-or-later
-#
-# This file is part of my nixos-config.
-#
-# You should have received a copy of the License along with this program.
-# If not, see <https://www.gnu.org/licenses/gpl-3.0.txt>.
-{
-  lib,
-  pkgs,
-  baseLib,
-  qmk_firmware,
-  system,
-  ...
-}: {
-  imports = [
-    ./hardware.nix
-  ];
-
-  soispha = {
-    bluetooth = {enable = true;};
-    networking = {
-      enable = true;
-      hostName = "tiamat";
-      mode = "systemd-networkd";
-    };
-    nixpkgs = {
-      enable = true;
-      systemName = "x86_64-linux";
-    };
-    services = {
-      unison.foreign.address = "apzu.fritz.box";
-    };
-    programs = {
-      river = {
-        unicodeInput.enable = true;
-        init = {
-          mappings = {
-            layout = "us";
-            keymap = let
-              map = key: "<Alt+Ctrl+Meta+Shift-${key}>";
-            in
-              (lib.mapAttrs' (name: value: lib.nameValuePair (map name) value) {
-                # Movement
-                "A" = {command = ["exit"];};
-                "B" = {command = ["close"];};
-
-                "C" = {command = ["focus-view" "previous"];};
-                "D" = {command = ["focus-view" "next"];};
-
-                "E" = {command = ["swap" "previous"];};
-                "F" = {command = ["swap" "next"];};
-
-                "G" = {command = ["zoom"];};
-
-                "H" = {command = ["toggle-fullscreen"];};
-                "I" = {command = ["toggle-float"];};
-
-                "J" = {command = ["send-to-output" "next"];};
-
-                "K" = {command = ["spawn" "${lib.getExe pkgs.alacritty}"];};
-                "L" = {command = ["spawn" "${lib.getExe pkgs.screenshot_persistent}"];};
-
-                # Audio
-                # "M" = {command = ["spawn" "video-pause toggle"]; modes = ["normal" "locked"]; };
-                "N" = {
-                  command = ["spawn" "${lib.getExe pkgs.mpc} toggle"];
-                  modes = ["normal" "locked"];
-                };
-
-                # Launcher
-                "O" = {command = ["spawn" "${lib.getExe pkgs.rofi} -show combi -modes combi -combi-modes 'window,drun,run' -show-icons"];};
-                "P" = {command = ["spawn" "${lib.getExe pkgs.tskm} open select"];};
-                "Q" = {command = ["spawn" "${lib.getExe pkgs.keepassxc}"];};
-                # "R" = {command = ["spawn" "nheko"];};
-                "S" = {command = ["spawn" "${lib.getExe pkgs.signal-desktop}"];};
-                "T" = {command = ["spawn" "${lib.getExe pkgs.lock}"];};
-
-                "U" = {command = ["focus-output" "next"];};
-                "V" = {command = ["focus-previous-tags"];};
-                "W" = {command = ["send-to-previous-tags"];};
-                # "X" = {command = ["spawn" "bemenu-run"];};
-                # "Y" = {command = ["spawn" "bemenu-run"];};
-
-                # Toggle all tags
-                "0" = {command = ["set-focused-tags" "${builtins.toString ((baseLib.pow 2 32) - 1)}"];};
-
-                # Support Unicode input
-                "Z" = {command = ["spawn" "${lib.getExe qmk_firmware.packages.${system}.qmk_unicode_type} 106 65377"];};
-              })
-              // ({
-                  # TODO: add toggle-focus mapping
-
-                  # Toggle all tags
-                  "<Alt+Ctrl+Shift-0>" = {command = ["set-view-tags" "${builtins.toString ((baseLib.pow 2 32) - 1)}"];};
-
-                  # Mouse
-                  "<Meta-<MOUSE_LEFT>>" = {
-                    command = ["move-view"];
-                    map_mode = "MapMouse";
-                  };
-                  "<Meta-<MOUSE_RIGHT>>" = {
-                    command = ["resize-view"];
-                    map_mode = "MapMouse";
-                  };
-                }
-                // (
-                  builtins.foldl' (acc: elem: acc // elem) {} (
-                    builtins.map (index: let
-                      num = builtins.toString index;
-                      index2tag = input: builtins.toString (baseLib.pow 2 (input - 1));
-                    in {
-                      "${map num}" = {command = ["set-focused-tags" (index2tag index)];};
-                      "<Alt+Ctrl+Shift-${num}>" = {command = ["set-view-tags" (index2tag index)];};
-                      # "<Super+Shift+Ctrl-${num}>" = {command = ["toggle-view-tags" (index2tag index)];};
-                    }) (builtins.genList (i: i + 1) 9)
-                  )
-                ));
-          };
-          screenSetupCode = {
-            "DP-2" = {pos = "2560,0";};
-            "DP-1" = {
-              scale = "1.5";
-              pos = "0,0";
-            };
-          };
-        };
-      };
-    };
-    locale = {
-      enable = true;
-      keyMap = "us";
-    };
-    users = {
-      enable = true;
-      enableDeprecatedPlugdev = true;
-      hashedPassword = "$y$jFT$qi3wS9njrMl2y55b3NOBI0$j40Qt6AAkMSfZ82KPhqMaUaPztWtPps1wOqaXaF/L.6";
-    };
-  };
-
-  system.stateVersion = "23.05";
-}