about summary refs log tree commit diff stats
path: root/hosts/marduk/networking.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-04-21 20:15:15 +0200
committerSoispha <soispha@vhack.eu>2023-05-09 19:31:19 +0200
commitda424f1cf5b656fa0bfab75b69038233dac1c81c (patch)
tree7f845a36599ddebfac9344ac0600a2731b28f754 /hosts/marduk/networking.nix
parentFix(hosts): Rename configuration.nix to default.nix (diff)
downloadnixos-config-da424f1cf5b656fa0bfab75b69038233dac1c81c.zip
Fix(hosts): Rename spawn to marduk to comply with scheme
Diffstat (limited to 'hosts/marduk/networking.nix')
-rw-r--r--hosts/marduk/networking.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/hosts/marduk/networking.nix b/hosts/marduk/networking.nix
new file mode 100644
index 00000000..da8f3850
--- /dev/null
+++ b/hosts/marduk/networking.nix
@@ -0,0 +1,14 @@
+{
+  config,
+  lib,
+  ...
+}: {
+  # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
+  # (the default) this is the recommended approach. When using systemd-networkd it's
+  # still possible to use this option, but it's recommended to use it in conjunction
+  # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
+  networking.useDHCP = lib.mkDefault true;
+  # networking.interfaces.enp0s31f6.useDHCP = lib.mkDefault true;
+  # networking.interfaces.wlp3s0.useDHCP = lib.mkDefault true;
+  networking.hostName = "marduk";
+}