about summary refs log tree commit diff stats
path: root/hosts/mammun/networking.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-20 11:06:12 +0100
committerene <ene@sils.li>2023-02-20 11:06:12 +0100
commit504d48d19b448203f8f1a59b2c1e3580908ad8c4 (patch)
tree68e97eee2d619c6908f8f7f35d3be210ca548363 /hosts/mammun/networking.nix
parentFeat(flake): Move the nixosConfigurations to a file (diff)
downloadnixos-config-504d48d19b448203f8f1a59b2c1e3580908ad8c4.zip
Fix(hosts): Use correct names and add mammun
Diffstat (limited to 'hosts/mammun/networking.nix')
-rw-r--r--hosts/mammun/networking.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/hosts/mammun/networking.nix b/hosts/mammun/networking.nix
new file mode 100644
index 00000000..05c7d100
--- /dev/null
+++ b/hosts/mammun/networking.nix
@@ -0,0 +1,14 @@
+{
+  config,
+  lib,
+  ...
+}: {
+  # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
+  # (the default) this is the recommended approach. When using systemd-networkd it's
+  # still possible to use this option, but it's recommended to use it in conjunction
+  # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
+  networking.useDHCP = lib.mkDefault true;
+  # networking.interfaces.enp0s31f6.useDHCP = lib.mkDefault true;
+  # networking.interfaces.wlp3s0.useDHCP = lib.mkDefault true;
+  networking.hostName = "mammun";
+}