about summary refs log tree commit diff stats
path: root/hosts/mammun/hardware/gpu.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-20 11:06:12 +0100
committerene <ene@sils.li>2023-02-20 11:06:12 +0100
commit504d48d19b448203f8f1a59b2c1e3580908ad8c4 (patch)
tree68e97eee2d619c6908f8f7f35d3be210ca548363 /hosts/mammun/hardware/gpu.nix
parentFeat(flake): Move the nixosConfigurations to a file (diff)
downloadnixos-config-504d48d19b448203f8f1a59b2c1e3580908ad8c4.zip
Fix(hosts): Use correct names and add mammun
Diffstat (limited to 'hosts/mammun/hardware/gpu.nix')
-rw-r--r--hosts/mammun/hardware/gpu.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/hosts/mammun/hardware/gpu.nix b/hosts/mammun/hardware/gpu.nix
new file mode 100644
index 00000000..c3df51ae
--- /dev/null
+++ b/hosts/mammun/hardware/gpu.nix
@@ -0,0 +1,15 @@
+{
+  config,
+  pkgs,
+  lib,
+  ...
+}: {
+  hardware.opengl.extraPackages = with pkgs; [
+    rocm-opencl-icd # open-cl
+    amdvlk # or directly through mesa
+    amd-media-driver # libva
+  ];
+
+  # Force radv, TODO is this logical?
+  environment.variables.AMD_VULKAN_ICD = "RADV";
+}