about summary refs log tree commit diff stats
path: root/hosts/Tiamat/hardware/gpu.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-04 22:16:25 +0100
committerene <ene@sils.li>2023-02-04 22:16:25 +0100
commita49d4ce07eb85c01c606e65b6dcfe9f2160773db (patch)
treed6176e9135de2ba0115b2dd1ffb8ed98cadebea1 /hosts/Tiamat/hardware/gpu.nix
parentFix: Used the correct syntax (diff)
downloadnixos-config-a49d4ce07eb85c01c606e65b6dcfe9f2160773db.zip
Feat: New host
I also changed the hostnames:
IDOHVE -> Tiamat
(laptop) -> Apzu
Diffstat (limited to 'hosts/Tiamat/hardware/gpu.nix')
-rw-r--r--hosts/Tiamat/hardware/gpu.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/hosts/Tiamat/hardware/gpu.nix b/hosts/Tiamat/hardware/gpu.nix
new file mode 100644
index 00000000..c3df51ae
--- /dev/null
+++ b/hosts/Tiamat/hardware/gpu.nix
@@ -0,0 +1,15 @@
+{
+  config,
+  pkgs,
+  lib,
+  ...
+}: {
+  hardware.opengl.extraPackages = with pkgs; [
+    rocm-opencl-icd # open-cl
+    amdvlk # or directly through mesa
+    amd-media-driver # libva
+  ];
+
+  # Force radv, TODO is this logical?
+  environment.variables.AMD_VULKAN_ICD = "RADV";
+}