about summary refs log tree commit diff stats
path: root/home-manager/soispha/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
committerSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
commit3f600ab07dbad3b6dd7655587ddea158b19aea71 (patch)
tree7164ccd965e1d14ade970aeb8eb188b1442a6c91 /home-manager/soispha/default.nix
parentStyle(treewide): Format all lua-files makes lua ➛ nix easier (diff)
downloadnixos-config-3f600ab07dbad3b6dd7655587ddea158b19aea71.zip
Refactor(treewide): Abbreviate path names
Diffstat (limited to 'home-manager/soispha/default.nix')
-rw-r--r--home-manager/soispha/default.nix61
1 files changed, 0 insertions, 61 deletions
diff --git a/home-manager/soispha/default.nix b/home-manager/soispha/default.nix
deleted file mode 100644
index 59fd7138..00000000
--- a/home-manager/soispha/default.nix
+++ /dev/null
@@ -1,61 +0,0 @@
-{
-  impermanence,
-  nixNeovim,
-  nixVim,
-  ...
-}: let
-  # TODO: actually use this in the user config
-  username = "soispha";
-  homeDirectory = "/home/${username}";
-
-  # xdg
-  configHome = "${homeDirectory}/.config";
-  dataHome = "${homeDirectory}/.local/share";
-  stateHome = "${homeDirectory}/.local/state";
-  cacheHome = "${homeDirectory}/.cache";
-  binHome = "${homeDirectory}/.local/bin";
-  # TODO: add XDG_RUNTIME_DIR
-in {
-  imports = [
-    ./config
-    ./files
-    ./impermanence
-    ./packages
-    ./wms
-
-    impermanence.nixosModules.home-manager.impermanence
-    nixNeovim.nixosModules.default
-    nixVim.homeManagerModules.nixvim
-  ];
-
-  # I don't know what this does, but I've seen it a lot online, so it should be good, right?
-  programs.home-manager.enable = true;
-
-  home = {
-    inherit username homeDirectory;
-    stateVersion = "23.05";
-    enableNixpkgsReleaseCheck = true;
-  };
-  xdg = {
-    inherit configHome dataHome stateHome cacheHome; #binHome; # TODO: add binHome, when the standart is extended
-    enable = true;
-
-    /*
-    TODO: add this
-    desktopEntries = {};
-    */
-
-    userDirs = {
-      enable = true;
-      createDirectories = true;
-      desktop = null;
-      documents = "${homeDirectory}/school/general";
-      download = "${homeDirectory}/media/downloads";
-      music = "${homeDirectory}/media/music";
-      pictures = "${homeDirectory}/media/pictures";
-      videos = "${homeDirectory}/media/videos";
-      templates = "${homeDirectory}/media/templates";
-      publicShare = "${homeDirectory}/media/public";
-    };
-  };
-}