about summary refs log tree commit diff stats
path: root/home-manager/soispha/config/swayidle/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-01 15:31:42 +0200
committerSoispha <soispha@vhack.eu>2023-08-01 15:42:54 +0200
commit0a608bd781dcda40144097b007fac0a0c60a8ee1 (patch)
treee69fbc1fd0e15e3b86f31f47b776df21f6f0170d /home-manager/soispha/config/swayidle/default.nix
parentFix(hm/conf/gammastep): Use lighter settings on laptops (diff)
downloadnixos-config-0a608bd781dcda40144097b007fac0a0c60a8ee1.zip
Refactor(treewide): Move module configuration in separate files
Diffstat (limited to 'home-manager/soispha/config/swayidle/default.nix')
-rw-r--r--home-manager/soispha/config/swayidle/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/home-manager/soispha/config/swayidle/default.nix b/home-manager/soispha/config/swayidle/default.nix
new file mode 100644
index 00000000..073498a7
--- /dev/null
+++ b/home-manager/soispha/config/swayidle/default.nix
@@ -0,0 +1,29 @@
+{
+  config,
+  pkgs,
+  ...
+}: {
+  xdg.configFile."swayidle/config".source = ./config;
+
+  #  services.swayidle = {
+  #    enable = true;
+  #    events = [
+  #      {
+  #        event = "before-sleep";
+  #        command = "${pkgs.swaylock}/bin/swaylock -f ";
+  #      }
+  #    ];
+  #    timeouts = [
+  #      {
+  #        timeout = 180;
+  #        command = "${pkgs.swaylock}/bin/swaylock -fFu ";
+  #      }
+  #      {
+  #        timeout = 360;
+  #        # TODO systemctl is installed?
+  #        command = "systemctl suspend-then-hibernate";
+  #      }
+  #    ];
+  #    # systemdTarget = ""; # TODO this might be usefull
+  #  };
+}