about summary refs log tree commit diff stats
path: root/home-manager/soispha/config/neovim/nixvim/plugins/todo-comments/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-26 22:33:02 +0200
committerSoispha <soispha@vhack.eu>2023-08-26 22:56:07 +0200
commitd22d6dca29dbf91ea65a861286f36347fc41e612 (patch)
treef23df54c6fc47dda6896f0d9220784ed90a59c11 /home-manager/soispha/config/neovim/nixvim/plugins/todo-comments/default.nix
parentFix(hm/conf/neovim/autocmds): Only show colorcolumn in insert mode (diff)
downloadnixos-config-d22d6dca29dbf91ea65a861286f36347fc41e612.zip
Feat(hm/conf/neovim/plugins/todo-comments): Init
Diffstat (limited to 'home-manager/soispha/config/neovim/nixvim/plugins/todo-comments/default.nix')
-rw-r--r--home-manager/soispha/config/neovim/nixvim/plugins/todo-comments/default.nix49
1 files changed, 49 insertions, 0 deletions
diff --git a/home-manager/soispha/config/neovim/nixvim/plugins/todo-comments/default.nix b/home-manager/soispha/config/neovim/nixvim/plugins/todo-comments/default.nix
new file mode 100644
index 00000000..f4d2b1c9
--- /dev/null
+++ b/home-manager/soispha/config/neovim/nixvim/plugins/todo-comments/default.nix
@@ -0,0 +1,49 @@
+{...}: {
+  programs.nixvim.plugins.todo-comments = {
+    enable = true;
+    guiStyle = {
+      fg = "BOLD";
+      bg = "NONE";
+    };
+    highlight = {
+      keyword = "wide_fg";
+    };
+    keywordds = {
+      /*
+      # Defaults:
+      FIX = {
+        icon = " "; # Icon used for the sign, and in search results.
+        color = "error"; # Can be a hex color, or a named color.
+        alt = ["FIXME" "BUG" "FIXIT" "ISSUE"]; # A set of other keywords that all map to this FIX keywords.
+      };
+      TODO = {
+        icon = " ";
+        color = "info";
+      };
+      HACK = {
+        icon = " ";
+        color = "warning";
+      };
+      WARN = {
+        icon = " ";
+        color = "warning";
+        alt = ["WARNING" "XXX"];
+      };
+      PERF = {
+        icon = " ";
+        alt = ["OPTIM" "PERFORMANCE" "OPTIMIZE"];
+      };
+      NOTE = {
+        icon = " ";
+        color = "hint";
+        alt = ["INFO"];
+      };
+      TEST = {
+        icon = "⏲ ";
+        color = "test";
+        alt = ["TESTING" "PASSED" "FAILED"];
+      };
+      */
+    };
+  };
+}