about summary refs log tree commit diff stats
path: root/home-manager/soispha/config/neovim/nixvim/plugins/nvim-cmp/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
committerSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
commit3f600ab07dbad3b6dd7655587ddea158b19aea71 (patch)
tree7164ccd965e1d14ade970aeb8eb188b1442a6c91 /home-manager/soispha/config/neovim/nixvim/plugins/nvim-cmp/default.nix
parentStyle(treewide): Format all lua-files makes lua ➛ nix easier (diff)
downloadnixos-config-3f600ab07dbad3b6dd7655587ddea158b19aea71.zip
Refactor(treewide): Abbreviate path names
Diffstat (limited to 'home-manager/soispha/config/neovim/nixvim/plugins/nvim-cmp/default.nix')
-rw-r--r--home-manager/soispha/config/neovim/nixvim/plugins/nvim-cmp/default.nix47
1 files changed, 0 insertions, 47 deletions
diff --git a/home-manager/soispha/config/neovim/nixvim/plugins/nvim-cmp/default.nix b/home-manager/soispha/config/neovim/nixvim/plugins/nvim-cmp/default.nix
deleted file mode 100644
index 2fd35272..00000000
--- a/home-manager/soispha/config/neovim/nixvim/plugins/nvim-cmp/default.nix
+++ /dev/null
@@ -1,47 +0,0 @@
-{...}: {
-  programs.nixvim.plugins.nvim-cmp = {
-    /*
-    TODO:; integrate this:
-    ```lua
-      enabled = {
-      function()
-          -- disable completion in comments
-          local context = require 'cmp.config.context'
-          -- keep command mode completion enabled when cursor is in a comment
-          -- te
-          if vim.api.nvim_get_mode().mode == 'c' then
-              return true
-          else
-              return not context.in_treesitter_capture("comment")
-                  and not context.in_syntax_group("Comment")
-          end
-      end
-      },
-    ```
-    */
-    enable = true;
-
-    mapping = {
-      # TODO: add support for desc and which key here
-      "<C-d>" = {
-        action = "cmp.mapping.scroll_docs(-4)";
-        #desc = "Scroll up by four lines";
-      };
-      "<C-f>" = {
-        action = "cmp.mapping.scroll_docs(4)";
-        #desc = "Scroll down by four lines";
-      };
-      "HH" = {
-        action = "cmp.mapping.complete()";
-        #desc = "Confirm snipped";
-      };
-    };
-
-    snippet.expand = "luasnip";
-
-    sources = [
-      {name = "nvim_lsp";}
-      {name = "luasnip";}
-    ];
-  };
-}