about summary refs log tree commit diff stats
path: root/home-manager/soispha/config/neovim/nixvim/plugins/goto-preview/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
committerSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
commit3f600ab07dbad3b6dd7655587ddea158b19aea71 (patch)
tree7164ccd965e1d14ade970aeb8eb188b1442a6c91 /home-manager/soispha/config/neovim/nixvim/plugins/goto-preview/default.nix
parentStyle(treewide): Format all lua-files makes lua ➛ nix easier (diff)
downloadnixos-config-3f600ab07dbad3b6dd7655587ddea158b19aea71.zip
Refactor(treewide): Abbreviate path names
Diffstat (limited to 'home-manager/soispha/config/neovim/nixvim/plugins/goto-preview/default.nix')
-rw-r--r--home-manager/soispha/config/neovim/nixvim/plugins/goto-preview/default.nix42
1 files changed, 0 insertions, 42 deletions
diff --git a/home-manager/soispha/config/neovim/nixvim/plugins/goto-preview/default.nix b/home-manager/soispha/config/neovim/nixvim/plugins/goto-preview/default.nix
deleted file mode 100644
index 740bb04c..00000000
--- a/home-manager/soispha/config/neovim/nixvim/plugins/goto-preview/default.nix
+++ /dev/null
@@ -1,42 +0,0 @@
-{
-  pkgs,
-  lib,
-  ...
-}: {
-  programs.nixvim = {
-    # TODO: package goto-preview though a module
-    extraConfigLuaPost = ''
-      ${lib.strings.fileContents ./lua/goto-preview.lua}
-    '';
-    extraPlugins = [
-      pkgs.vimExtraPlugins.goto-preview
-    ];
-    maps.normal = {
-      "<space>gd" = {
-        action = "require('goto-preview').goto_preview_definition";
-        lua = true;
-        desc = "[G]oto [D]efinition";
-      };
-      "<space>gtd" = {
-        action = "require('goto-preview').goto_preview_type_definition";
-        lua = true;
-        desc = "[G]oto the [t]ype [D]efinition";
-      };
-      "<space>gi" = {
-        action = "require('goto-preview').goto_preview_implementation";
-        lua = true;
-        desc = "[G]oto [I]mplementations";
-      };
-      "<space>gr" = {
-        action = "require('goto-preview').goto_preview_references";
-        lua = true;
-        desc = "[G]o to all [R]eferences of the symbol";
-      };
-      "\\<space>" = {
-        action = "require('goto-preview').close_all_win";
-        lua = true;
-        desc = "close all preview windows";
-      };
-    };
-  };
-}