about summary refs log tree commit diff stats
path: root/home-manager/soispha/config/neovim/nixvim/plugins/femaco/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-25 23:05:19 +0200
committerSoispha <soispha@vhack.eu>2023-08-25 23:05:19 +0200
commit79c9e4213a2bd69f82df777ba18ed6142d9d58c2 (patch)
tree6d4032015ff9b8625f2351dabb99dcf507193e7c /home-manager/soispha/config/neovim/nixvim/plugins/femaco/default.nix
parentFix(flake/packages): Make it obvious that 'vim' is actually 'nvim' (diff)
downloadnixos-config-79c9e4213a2bd69f82df777ba18ed6142d9d58c2.zip
Feat(hm/conf/neovim/plugins/femaco): Init
Diffstat (limited to 'home-manager/soispha/config/neovim/nixvim/plugins/femaco/default.nix')
-rw-r--r--home-manager/soispha/config/neovim/nixvim/plugins/femaco/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/home-manager/soispha/config/neovim/nixvim/plugins/femaco/default.nix b/home-manager/soispha/config/neovim/nixvim/plugins/femaco/default.nix
new file mode 100644
index 00000000..7e641da4
--- /dev/null
+++ b/home-manager/soispha/config/neovim/nixvim/plugins/femaco/default.nix
@@ -0,0 +1,24 @@
+{
+  pkgs,
+  lib,
+  ...
+}: {
+  programs.nixvim = {
+    # TODO package femaco though a module
+    extraConfigLuaPost = ''
+      ${lib.strings.fileContents ./lua/femaco.lua}
+    '';
+    extraPlugins = [
+      pkgs.vimPlugins.nvim-FeMaco-lua
+    ];
+    maps = {
+      normal = {
+        "<leader>cc" = {
+          action = "require('femaco.edit').edit_code_block()";
+          lua = true;
+          desc = "edit a [c]ode blo[c]k with femaco";
+        };
+      };
+    };
+  };
+}