about summary refs log tree commit diff stats
path: root/home-manager/soispha/config/neovim/nixvim/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-03 21:34:16 +0200
committerSoispha <soispha@vhack.eu>2023-08-19 17:34:47 +0200
commitbe1cc38bdb83e6716b08d24cc1201fffc6649311 (patch)
treec3691569e0e8858b672b501096b6cb5edd39daf6 /home-manager/soispha/config/neovim/nixvim/default.nix
parentFeat(treewide): Import nixVim (diff)
downloadnixos-config-be1cc38bdb83e6716b08d24cc1201fffc6649311.zip
Feat(hm/conf/nvim): Add basic nix config [REBASE TARGET]
Diffstat (limited to 'home-manager/soispha/config/neovim/nixvim/default.nix')
-rw-r--r--home-manager/soispha/config/neovim/nixvim/default.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/home-manager/soispha/config/neovim/nixvim/default.nix b/home-manager/soispha/config/neovim/nixvim/default.nix
new file mode 100644
index 00000000..f216fb05
--- /dev/null
+++ b/home-manager/soispha/config/neovim/nixvim/default.nix
@@ -0,0 +1,39 @@
+{
+  pkgs,
+  ...
+}: {
+  imports = [
+    ./options
+    ./mappings
+    ./colorscheme
+    ./clipboard
+  ];
+  programs.nixvim = {
+    enable = true;
+    defaultEditor = true;
+
+    # to install plugins just activate their modules
+    plugins = {
+      lsp = {
+        enable = true;
+        hls.enable = true;
+        rust-analyzer.enable = true;
+      };
+      treesitter = {
+        enable = true;
+        indent = true;
+      };
+      mini = {
+        enable = true;
+        ai.enable = true;
+        jump.enable = true;
+      };
+    };
+
+    # Not all plugins have own modules
+    # You can add missing plugins here
+    # `pkgs.vimExtraPlugins` is added by the overlay you added at the beginning
+    # For a list of available plugins, look here: [available plugins](https://github.com/jooooscha/nixpkgs-vim-extra-plugins/blob/main/plugins.md)
+    extraPlugins = [pkgs.vimExtraPlugins.nightfox-nvim];
+  };
+}