about summary refs log tree commit diff stats
path: root/home-manager/soispha/config/neovim/nixvim/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
committerSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
commit3f600ab07dbad3b6dd7655587ddea158b19aea71 (patch)
tree7164ccd965e1d14ade970aeb8eb188b1442a6c91 /home-manager/soispha/config/neovim/nixvim/default.nix
parentStyle(treewide): Format all lua-files makes lua ➛ nix easier (diff)
downloadnixos-config-3f600ab07dbad3b6dd7655587ddea158b19aea71.zip
Refactor(treewide): Abbreviate path names
Diffstat (limited to 'home-manager/soispha/config/neovim/nixvim/default.nix')
-rw-r--r--home-manager/soispha/config/neovim/nixvim/default.nix48
1 files changed, 0 insertions, 48 deletions
diff --git a/home-manager/soispha/config/neovim/nixvim/default.nix b/home-manager/soispha/config/neovim/nixvim/default.nix
deleted file mode 100644
index 61467618..00000000
--- a/home-manager/soispha/config/neovim/nixvim/default.nix
+++ /dev/null
@@ -1,48 +0,0 @@
-{
-  pkgs,
-  lib,
-  ...
-}: {
-  imports = [
-    ./autocmds
-    ./clipboard
-    ./files
-    ./mappings
-    ./options
-    ./plugins
-  ];
-  programs.nixvim = {
-    enable = true;
-
-    # source: https://www.patorjk.com/software/taag/#p=display&f=ANSI%20Shadow&t=Neovim
-    extraConfigLuaPre = lib.mkBefore ''
-      ---------------------------------------------------------------------------
-      --
-      --     ███╗   ██╗███████╗ ██████╗ ██╗   ██╗██╗███╗   ███╗
-      --     ████╗  ██║██╔════╝██╔═══██╗██║   ██║██║████╗ ████║
-      --     ██╔██╗ ██║█████╗  ██║   ██║██║   ██║██║██╔████╔██║
-      --     ██║╚██╗██║██╔══╝  ██║   ██║╚██╗ ██╔╝██║██║╚██╔╝██║
-      --     ██║ ╚████║███████╗╚██████╔╝ ╚████╔╝ ██║██║ ╚═╝ ██║
-      --     ╚═╝  ╚═══╝╚══════╝ ╚═════╝   ╚═══╝  ╚═╝╚═╝     ╚═╝
-      --
-      ---------------------------------------------------------------------------
-    '';
-
-    extraPackages = with pkgs; [
-      /*
-      These are mostly linters and formatters used for different file types.
-      Including them here is fine, as they are not necessarily sync able to different people.
-      */
-      # nix
-      alejandra
-      statix
-
-      # yaml
-      yamllint
-
-      # shell
-      shellcheck
-      shfmt
-    ];
-  };
-}