about summary refs log tree commit diff stats
path: root/home-manager/soispha/config/lf/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
committerSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
commit3f600ab07dbad3b6dd7655587ddea158b19aea71 (patch)
tree7164ccd965e1d14ade970aeb8eb188b1442a6c91 /home-manager/soispha/config/lf/default.nix
parentStyle(treewide): Format all lua-files makes lua ➛ nix easier (diff)
downloadnixos-config-3f600ab07dbad3b6dd7655587ddea158b19aea71.zip
Refactor(treewide): Abbreviate path names
Diffstat (limited to 'home-manager/soispha/config/lf/default.nix')
-rw-r--r--home-manager/soispha/config/lf/default.nix53
1 files changed, 0 insertions, 53 deletions
diff --git a/home-manager/soispha/config/lf/default.nix b/home-manager/soispha/config/lf/default.nix
deleted file mode 100644
index ed037b05..00000000
--- a/home-manager/soispha/config/lf/default.nix
+++ /dev/null
@@ -1,53 +0,0 @@
-{
-  pkgs,
-  sysLib,
-  nixosConfig,
-  shell_library,
-  lf_rename,
-  system,
-  ...
-}: let
-  commands = import ./commands {inherit pkgs sysLib shell_library system lf_rename;};
-  keybindings = import ./keybindings {inherit nixosConfig;};
-in {
-  xdg.configFile."lf/icons".source = ./icons;
-  xdg.configFile."lf/colors".source = ./colors;
-
-  # TODO: add the systemd tempfile option here
-
-  programs.lf = {
-    enable = true;
-
-    inherit commands keybindings;
-
-    previewer = {
-      keybinding = "i";
-      source = "${pkgs.ctpv}/bin/ctpv";
-    };
-    settings = {
-      # TODO: this needs to be added to nixos:
-      #autoquit = true; # quit the server, if no clients are left
-      #dirpreviews = true; # preview for directories
-
-      dircounts = true; # count things in directories TODO: this has performance impact
-      drawbox = true;
-      # errorfmt = "\\033[1;91m==> ERROR:\\033[0m\\033[1;93m%s\\033[0m";
-      errorfmt = "\\033[1;91m%s\\033[0m";
-      hidden = true; # show hidden files
-      icons = true;
-      ifs = "\\n"; # internal field separator for shell commands
-      #info = "size"; # show the size of a directory
-      shell = "sh";
-      shellopts = "-eu"; # e: exit on error; u: error for unset variables
-    };
-    # TODO: remove auto quit, if it has been added
-    extraConfig = ''
-      &${pkgs.ctpv}/bin/ctpv -s $id
-      cmd on-quit %${pkgs.ctpv}/bin/ctpv -e $id
-      set cleaner ${pkgs.ctpv}/bin/ctpvclear
-
-      # close the server, after the last client exits
-      set autoquit true
-    '';
-  };
-}