about summary refs log tree commit diff stats
path: root/home-manager/soispha/config/lf/commands/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-25 22:29:35 +0200
committerSoispha <soispha@vhack.eu>2023-08-25 22:29:35 +0200
commitbd9d18ef58e3104a25680b84504d1491789bd349 (patch)
tree22850ef87bd62d1fc8bb9a32d2bf4462ad0d682a /home-manager/soispha/config/lf/commands/default.nix
parentBuild(flake): Update (diff)
downloadnixos-config-bd9d18ef58e3104a25680b84504d1491789bd349.zip
Feat(hm/conf/lf): Add command to go to flake base dir
Diffstat (limited to 'home-manager/soispha/config/lf/commands/default.nix')
-rw-r--r--home-manager/soispha/config/lf/commands/default.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/home-manager/soispha/config/lf/commands/default.nix b/home-manager/soispha/config/lf/commands/default.nix
index a915a21c..80d20ca8 100644
--- a/home-manager/soispha/config/lf/commands/default.nix
+++ b/home-manager/soispha/config/lf/commands/default.nix
@@ -172,6 +172,10 @@ in {
     file = ./scripts/open;
     dependencies = builtins.attrValues {inherit (pkgs) file xdg-utils;};
   };
+  go_project_base_directory = async {
+    file = ./scripts/go_project_root;
+    dependencies = [];
+  };
   open_config = shell {
     file = ./scripts/open_config;
     dependencies = builtins.attrValues {