about summary refs log tree commit diff stats
path: root/home-manager/soispha/config/lf/commands/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-19 23:09:26 +0200
committerSoispha <soispha@vhack.eu>2023-08-19 23:09:26 +0200
commit7d99e6f2d84cbcf51553f26e2abc82a106592c16 (patch)
treed7f74629ae0aac7199f70a1e5a48c487eded06dd /home-manager/soispha/config/lf/commands/default.nix
parentFix(hm/conf/lf): Split file creation and edit of the made file cmds (diff)
downloadnixos-config-7d99e6f2d84cbcf51553f26e2abc82a106592c16.zip
Fix(hm/conf/lf): Implement rename cmd
The default lf rename command starts behind the extension like this:
```
filename.extension
       ^
       |
   startpoint
```
This new cmd avoids this.
Diffstat (limited to 'home-manager/soispha/config/lf/commands/default.nix')
-rw-r--r--home-manager/soispha/config/lf/commands/default.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/home-manager/soispha/config/lf/commands/default.nix b/home-manager/soispha/config/lf/commands/default.nix
index c8652442..fa366d37 100644
--- a/home-manager/soispha/config/lf/commands/default.nix
+++ b/home-manager/soispha/config/lf/commands/default.nix
@@ -196,6 +196,10 @@ in {
     file = ./scripts/set_wall_paper;
     dependencies = [];
   };
+  rename = pipe {
+    file = ./scripts/rename;
+    dependencies = [];
+  };
   stripspace = pipe {
     file = ./scripts/stripspace;
     dependencies = [];