about summary refs log tree commit diff stats
path: root/home-manager/soispha/config/lf/commands/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-20 19:05:35 +0200
committerSoispha <soispha@vhack.eu>2023-08-20 19:05:35 +0200
commit69099861601d5649df737d82021a0cf5abb51403 (patch)
treee699b45ce420a56ca5f0bd17efe8fad74e73f3b5 /home-manager/soispha/config/lf/commands/default.nix
parentFix(hm/conf/neovim/plugins/luasnip): Correct local value in snippet (diff)
downloadnixos-config-69099861601d5649df737d82021a0cf5abb51403.zip
Feat(hm/conf/lf): Replace rename script by rename c binary
Diffstat (limited to 'home-manager/soispha/config/lf/commands/default.nix')
-rw-r--r--home-manager/soispha/config/lf/commands/default.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/home-manager/soispha/config/lf/commands/default.nix b/home-manager/soispha/config/lf/commands/default.nix
index fa366d37..95cd2991 100644
--- a/home-manager/soispha/config/lf/commands/default.nix
+++ b/home-manager/soispha/config/lf/commands/default.nix
@@ -3,6 +3,7 @@
   sysLib,
   shell_library,
   system,
+  lf_rename,
   ...
 }: let
   functionCall = {
@@ -197,7 +198,7 @@ in {
     dependencies = [];
   };
   rename = pipe {
-    file = ./scripts/rename;
+    file = "${lf_rename.packages."${system}".default}";
     dependencies = [];
   };
   stripspace = pipe {