about summary refs log tree commit diff stats
path: root/home-manager/packages/script.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-25 08:16:22 +0100
committerene <ene@sils.li>2023-02-25 08:16:22 +0100
commite122458eb397dfb892bca8c55af1536bbf25edfb (patch)
tree9eab137f8254cce83b1932bce68fc28a06025c58 /home-manager/packages/script.nix
parentFix(hosts): Add different password for mammun (diff)
downloadnixos-config-e122458eb397dfb892bca8c55af1536bbf25edfb.zip
Fix(packages): Fix typo in name
Diffstat (limited to 'home-manager/packages/script.nix')
-rw-r--r--home-manager/packages/script.nix91
1 files changed, 0 insertions, 91 deletions
diff --git a/home-manager/packages/script.nix b/home-manager/packages/script.nix
deleted file mode 100644
index 104825ff..00000000
--- a/home-manager/packages/script.nix
+++ /dev/null
@@ -1,91 +0,0 @@
-{
-  pkgs,
-  sysLib,
-  ...
-}: let
-  write_script = {
-    name,
-    path,
-    dependencies,
-  }:
-    sysLib.makeShellScriptWithLibrary {
-      inherit name;
-      script = ./scripts/${path}/${name};
-      dependencies = dependencies ++ [pkgs.dash];
-    };
-  aumo-scr = write_script {
-    name = "aumo";
-    path = "apps";
-    dependencies = builtins.attrValues {inherit (pkgs) udisks gawk gnused gnugrep sudo;};
-  };
-  con2pdf-scr = write_script {
-    name = "con2pdf";
-    path = "apps";
-    dependencies = builtins.attrValues {inherit (pkgs) sane-backends imagemagick;};
-  };
-
-  dldragon-scr = write_script {
-    name = "dldragon";
-    path = "small_functions";
-    dependencies = builtins.attrValues {inherit (pkgs) curl xdragon;};
-  };
-  gtk-themes-scr = write_script {
-    name = "gtk-themes";
-    path = "small_functions";
-    dependencies = builtins.attrValues {inherit (pkgs) glib;};
-  };
-  screen_shot-scr = write_script {
-    name = "screen_shot";
-    path = "small_functions";
-    dependencies = builtins.attrValues {inherit (pkgs) grim slurp alacritty;}; # TODO add llp
-  };
-  mocs-scr = write_script {
-    name = "mocs";
-    path = "small_functions";
-    dependencies = builtins.attrValues {inherit (pkgs) moc procps;}; # TODO add mymocp
-  };
-
-  backsnap-scr = write_script {
-    name = "backsnap";
-    path = "wrappers";
-    dependencies = builtins.attrValues {}; # TODO add snap-sync
-  };
-  ll-scr = write_script {
-    name = "ll";
-    path = "wrappers";
-    dependencies = builtins.attrValues {inherit (pkgs) lf;};
-  };
-  llp-scr = write_script {
-    name = "llp";
-    path = "wrappers";
-    dependencies = builtins.attrValues {inherit (pkgs) lf ueberzug;};
-  };
-  spodi-scr = write_script {
-    name = "spodi";
-    path = "wrappers";
-    dependencies = builtins.attrValues {inherit (pkgs) gawk expect spotdl;};
-  };
-  virsh-del-scr = write_script {
-    name = "virsh-del";
-    path = "wrappers";
-    dependencies = builtins.attrValues {inherit (pkgs) libvirt;};
-  };
-  yti-scr = write_script {
-    name = "yti";
-    path = "wrappers";
-    dependencies = builtins.attrValues {inherit (pkgs) gawk expect yt-dlp;};
-  };
-in [
-  aumo-scr
-  con2pdf-scr
-  dldragon-scr
-  gtk-themes-scr
-  screen_shot-scr
-  mocs-scr
-  backsnap-scr
-  ll-scr
-  llp-scr
-  spodi-scr
-  virsh-del-scr
-  yti-scr
-]