about summary refs log tree commit diff stats
path: root/hm/soispha/wms/river/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-12-17 10:07:58 +0100
committerSoispha <soispha@vhack.eu>2023-12-17 10:07:58 +0100
commitabed162c54ad434c8a723aabba74ec98b5ae8f68 (patch)
tree4645ca0f5cd6ebe9c2ac22ea00921f76bda46d45 /hm/soispha/wms/river/default.nix
parentfix(hm/pkgs/scr/spodi): Use the full range of audio providers (diff)
downloadnixos-config-abed162c54ad434c8a723aabba74ec98b5ae8f68.zip
fix(hm/wms/river/init): Set env vars from nix config
Recursive variable assignment is apparently not supported by posix shell.
Diffstat (limited to 'hm/soispha/wms/river/default.nix')
-rw-r--r--hm/soispha/wms/river/default.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/hm/soispha/wms/river/default.nix b/hm/soispha/wms/river/default.nix
index 30b3b016..9965f5a8 100644
--- a/hm/soispha/wms/river/default.nix
+++ b/hm/soispha/wms/river/default.nix
@@ -35,9 +35,10 @@
       err_fail gammastep &
     ''
     else builtins.throw "Host not covered in river screen setup";
+    env_vars = "XDG_CURRENT_DESKTOP=river DESKTOP_SESSION=river";
   init_scr = pkgs.substituteAll {
     src = ./init;
-    inherit mappings screen_setup;
+    inherit mappings screen_setup env_vars;
   };
 in {
   xdg.configFile."river/init".source =