about summary refs log tree commit diff stats
path: root/hm/soispha/conf/swayidle/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
committerSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
commit3f600ab07dbad3b6dd7655587ddea158b19aea71 (patch)
tree7164ccd965e1d14ade970aeb8eb188b1442a6c91 /hm/soispha/conf/swayidle/default.nix
parentStyle(treewide): Format all lua-files makes lua ➛ nix easier (diff)
downloadnixos-config-3f600ab07dbad3b6dd7655587ddea158b19aea71.zip
Refactor(treewide): Abbreviate path names
Diffstat (limited to 'hm/soispha/conf/swayidle/default.nix')
-rw-r--r--hm/soispha/conf/swayidle/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/hm/soispha/conf/swayidle/default.nix b/hm/soispha/conf/swayidle/default.nix
new file mode 100644
index 00000000..6b8a7d80
--- /dev/null
+++ b/hm/soispha/conf/swayidle/default.nix
@@ -0,0 +1,29 @@
+{
+  config,
+  pkgs,
+  ...
+}: {
+  xdg.configFile."swayidle/config".source = ./config;
+
+  #  services.swayidle = {
+  #    enable = true;
+  #    events = [
+  #      {
+  #        event = "before-sleep";
+  #        command = "${pkgs.swaylock}/bin/swaylock -f ";
+  #      }
+  #    ];
+  #    timeouts = [
+  #      {
+  #        timeout = 180;
+  #        command = "${pkgs.swaylock}/bin/swaylock -fFu ";
+  #      }
+  #      {
+  #        timeout = 360;
+  #        # TODO: systemctl is installed?
+  #        command = "systemctl suspend-then-hibernate";
+  #      }
+  #    ];
+  #    # systemdTarget = ""; # TODO: this might be usefull
+  #  };
+}