about summary refs log tree commit diff stats
path: root/hm/soispha/conf/nvim/plugins/leap/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
committerSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
commit3f600ab07dbad3b6dd7655587ddea158b19aea71 (patch)
tree7164ccd965e1d14ade970aeb8eb188b1442a6c91 /hm/soispha/conf/nvim/plugins/leap/default.nix
parentStyle(treewide): Format all lua-files makes lua ➛ nix easier (diff)
downloadnixos-config-3f600ab07dbad3b6dd7655587ddea158b19aea71.zip
Refactor(treewide): Abbreviate path names
Diffstat (limited to 'hm/soispha/conf/nvim/plugins/leap/default.nix')
-rw-r--r--hm/soispha/conf/nvim/plugins/leap/default.nix58
1 files changed, 58 insertions, 0 deletions
diff --git a/hm/soispha/conf/nvim/plugins/leap/default.nix b/hm/soispha/conf/nvim/plugins/leap/default.nix
new file mode 100644
index 00000000..bffdf33c
--- /dev/null
+++ b/hm/soispha/conf/nvim/plugins/leap/default.nix
@@ -0,0 +1,58 @@
+{...}: {
+  programs.nixvim = {
+    plugins.leap = {
+      enable = true;
+      addDefaultMappings = false; # They don't work with dvorak.
+      safeLabels = [
+        "f"
+        "j"
+        "k"
+        "l"
+        "/"
+        "z"
+        "S"
+        "F"
+        "J"
+        "K"
+        "L"
+        "H"
+        "W"
+        "E"
+        "M"
+        "B"
+        "U"
+        "X"
+        "?"
+        "Z"
+      ];
+    };
+    maps = {
+      normalVisualOp = {
+        "m" = {
+          action = "<Plug>(leap-forward-to)";
+          desc = "leap forward to";
+        };
+        "M" = {
+          action = "<Plug>(leap-backward-to)";
+          desc = "leap backward to";
+        };
+        "gs" = {
+          action = "<Plug>(leap-from-window)";
+          desc = "leap to enterable windows";
+        };
+      };
+      visual = {
+        /*
+        "x" = {
+          action = "<Plug>(leap-forward-till)";
+          desc = "leap forward till";
+        };
+        "X" = {
+          action = "<Plug>(leap-backward-till)";
+          desc = "leap backward till";
+        };
+        */
+      };
+    };
+  };
+}