about summary refs log tree commit diff stats
path: root/hm/soispha/conf/nvim/plugins/goto-preview/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-29 21:33:43 +0200
committerSoispha <soispha@vhack.eu>2023-08-29 21:33:43 +0200
commit3925f6ee04f09d7d09b7aff018812670a0e89492 (patch)
tree12642e7332ebb53153bef1bf5d5f811e3f19884b /hm/soispha/conf/nvim/plugins/goto-preview/default.nix
parentFeat(hm/conf/nvim/plgs/debugprint): Init (diff)
downloadnixos-config-3925f6ee04f09d7d09b7aff018812670a0e89492.zip
Refactor(hm/conf/nvim/plugins): Rename to `plgs` to safe commit msg space
Diffstat (limited to 'hm/soispha/conf/nvim/plugins/goto-preview/default.nix')
-rw-r--r--hm/soispha/conf/nvim/plugins/goto-preview/default.nix42
1 files changed, 0 insertions, 42 deletions
diff --git a/hm/soispha/conf/nvim/plugins/goto-preview/default.nix b/hm/soispha/conf/nvim/plugins/goto-preview/default.nix
deleted file mode 100644
index 740bb04c..00000000
--- a/hm/soispha/conf/nvim/plugins/goto-preview/default.nix
+++ /dev/null
@@ -1,42 +0,0 @@
-{
-  pkgs,
-  lib,
-  ...
-}: {
-  programs.nixvim = {
-    # TODO: package goto-preview though a module
-    extraConfigLuaPost = ''
-      ${lib.strings.fileContents ./lua/goto-preview.lua}
-    '';
-    extraPlugins = [
-      pkgs.vimExtraPlugins.goto-preview
-    ];
-    maps.normal = {
-      "<space>gd" = {
-        action = "require('goto-preview').goto_preview_definition";
-        lua = true;
-        desc = "[G]oto [D]efinition";
-      };
-      "<space>gtd" = {
-        action = "require('goto-preview').goto_preview_type_definition";
-        lua = true;
-        desc = "[G]oto the [t]ype [D]efinition";
-      };
-      "<space>gi" = {
-        action = "require('goto-preview').goto_preview_implementation";
-        lua = true;
-        desc = "[G]oto [I]mplementations";
-      };
-      "<space>gr" = {
-        action = "require('goto-preview').goto_preview_references";
-        lua = true;
-        desc = "[G]o to all [R]eferences of the symbol";
-      };
-      "\\<space>" = {
-        action = "require('goto-preview').close_all_win";
-        lua = true;
-        desc = "close all preview windows";
-      };
-    };
-  };
-}