about summary refs log tree commit diff stats
path: root/hm/soispha/conf/nvim/plugins/femaco/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
committerSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
commit3f600ab07dbad3b6dd7655587ddea158b19aea71 (patch)
tree7164ccd965e1d14ade970aeb8eb188b1442a6c91 /hm/soispha/conf/nvim/plugins/femaco/default.nix
parentStyle(treewide): Format all lua-files makes lua ➛ nix easier (diff)
downloadnixos-config-3f600ab07dbad3b6dd7655587ddea158b19aea71.zip
Refactor(treewide): Abbreviate path names
Diffstat (limited to 'hm/soispha/conf/nvim/plugins/femaco/default.nix')
-rw-r--r--hm/soispha/conf/nvim/plugins/femaco/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/hm/soispha/conf/nvim/plugins/femaco/default.nix b/hm/soispha/conf/nvim/plugins/femaco/default.nix
new file mode 100644
index 00000000..6d7ec16a
--- /dev/null
+++ b/hm/soispha/conf/nvim/plugins/femaco/default.nix
@@ -0,0 +1,24 @@
+{
+  pkgs,
+  lib,
+  ...
+}: {
+  programs.nixvim = {
+    # TODO: package femaco though a module
+    extraConfigLuaPost = ''
+      ${lib.strings.fileContents ./lua/femaco.lua}
+    '';
+    extraPlugins = [
+      pkgs.vimPlugins.nvim-FeMaco-lua
+    ];
+    maps = {
+      normal = {
+        "<leader>cc" = {
+          action = "require('femaco.edit').edit_code_block()";
+          lua = true;
+          desc = "edit a [c]ode blo[c]k with femaco";
+        };
+      };
+    };
+  };
+}