about summary refs log tree commit diff stats
path: root/hm/soispha/conf/nvim/plgs/ltex_extra/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-29 21:33:43 +0200
committerSoispha <soispha@vhack.eu>2023-08-29 21:33:43 +0200
commit3925f6ee04f09d7d09b7aff018812670a0e89492 (patch)
tree12642e7332ebb53153bef1bf5d5f811e3f19884b /hm/soispha/conf/nvim/plgs/ltex_extra/default.nix
parentFeat(hm/conf/nvim/plgs/debugprint): Init (diff)
downloadnixos-config-3925f6ee04f09d7d09b7aff018812670a0e89492.zip
Refactor(hm/conf/nvim/plugins): Rename to `plgs` to safe commit msg space
Diffstat (limited to 'hm/soispha/conf/nvim/plgs/ltex_extra/default.nix')
-rw-r--r--hm/soispha/conf/nvim/plgs/ltex_extra/default.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/hm/soispha/conf/nvim/plgs/ltex_extra/default.nix b/hm/soispha/conf/nvim/plgs/ltex_extra/default.nix
new file mode 100644
index 00000000..3d1c60fc
--- /dev/null
+++ b/hm/soispha/conf/nvim/plgs/ltex_extra/default.nix
@@ -0,0 +1,9 @@
+{pkgs, ...}: {
+  programs.nixvim = {
+    # TODO: package ltex_extra though a module
+    extraPlugins = [
+      pkgs.vimExtraPlugins.ltex-extra-nvim
+    ];
+    plugins.lsp.servers.ltex.onAttach.function = builtins.readFile ./lua/ltex_extra.lua;
+  };
+}