about summary refs log tree commit diff stats
path: root/hm/soispha/conf/nvim/plgs/goto-preview/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-10-08 13:12:44 +0200
committerSoispha <soispha@vhack.eu>2023-10-08 13:12:44 +0200
commit8fbcfc8698f97fc4701d09cb3de3e095d5ddd7c7 (patch)
tree90530153a36e969569115c6e06ea17c473826670 /hm/soispha/conf/nvim/plgs/goto-preview/default.nix
parentchore(version): v1.15.0 (diff)
downloadnixos-config-8fbcfc8698f97fc4701d09cb3de3e095d5ddd7c7.zip
fix(hm/conf/nvim): Update to new keymap format
Diffstat (limited to 'hm/soispha/conf/nvim/plgs/goto-preview/default.nix')
-rw-r--r--hm/soispha/conf/nvim/plgs/goto-preview/default.nix44
1 files changed, 27 insertions, 17 deletions
diff --git a/hm/soispha/conf/nvim/plgs/goto-preview/default.nix b/hm/soispha/conf/nvim/plgs/goto-preview/default.nix
index 740bb04c..70527b93 100644
--- a/hm/soispha/conf/nvim/plgs/goto-preview/default.nix
+++ b/hm/soispha/conf/nvim/plgs/goto-preview/default.nix
@@ -11,32 +11,42 @@
     extraPlugins = [
       pkgs.vimExtraPlugins.goto-preview
     ];
-    maps.normal = {
-      "<space>gd" = {
+    keymaps = [
+      {
+        key = "<space>gd";
+        mode = "n";
         action = "require('goto-preview').goto_preview_definition";
         lua = true;
-        desc = "[G]oto [D]efinition";
-      };
-      "<space>gtd" = {
+        options.desc = "[G]oto [D]efinition";
+      }
+      {
+        key = "<space>gtd";
+        mode = "n";
         action = "require('goto-preview').goto_preview_type_definition";
         lua = true;
-        desc = "[G]oto the [t]ype [D]efinition";
-      };
-      "<space>gi" = {
+        options.desc = "[G]oto the [t]ype [D]efinition";
+      }
+      {
+        key = "<space>gi";
+        mode = "n";
         action = "require('goto-preview').goto_preview_implementation";
         lua = true;
-        desc = "[G]oto [I]mplementations";
-      };
-      "<space>gr" = {
+        options.desc = "[G]oto [I]mplementations";
+      }
+      {
+        key = "<space>gr";
+        mode = "n";
         action = "require('goto-preview').goto_preview_references";
         lua = true;
-        desc = "[G]o to all [R]eferences of the symbol";
-      };
-      "\\<space>" = {
+        options.desc = "[G]o to all [R]eferences of the symbol";
+      }
+      {
+        key = "\\<space>";
+        mode = "n";
         action = "require('goto-preview').close_all_win";
         lua = true;
-        desc = "close all preview windows";
-      };
-    };
+        options.desc = "close all preview windows";
+      }
+    ];
   };
 }