about summary refs log tree commit diff stats
path: root/hm/soispha/conf/nvim/plgs/comment-nvim/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-29 21:33:43 +0200
committerSoispha <soispha@vhack.eu>2023-08-29 21:33:43 +0200
commit3925f6ee04f09d7d09b7aff018812670a0e89492 (patch)
tree12642e7332ebb53153bef1bf5d5f811e3f19884b /hm/soispha/conf/nvim/plgs/comment-nvim/default.nix
parentFeat(hm/conf/nvim/plgs/debugprint): Init (diff)
downloadnixos-config-3925f6ee04f09d7d09b7aff018812670a0e89492.zip
Refactor(hm/conf/nvim/plugins): Rename to `plgs` to safe commit msg space
Diffstat (limited to 'hm/soispha/conf/nvim/plgs/comment-nvim/default.nix')
-rw-r--r--hm/soispha/conf/nvim/plgs/comment-nvim/default.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/hm/soispha/conf/nvim/plgs/comment-nvim/default.nix b/hm/soispha/conf/nvim/plgs/comment-nvim/default.nix
new file mode 100644
index 00000000..cf99d3d5
--- /dev/null
+++ b/hm/soispha/conf/nvim/plgs/comment-nvim/default.nix
@@ -0,0 +1,36 @@
+{...}: {
+  programs.nixvim = {
+    plugins.comment-nvim = {
+      enable = true;
+      padding = true;
+      sticky = true;
+      mappings = {
+        basic = false;
+        extended = false;
+        extra = false;
+      };
+    };
+    maps = {
+      visual = {
+        "gcc" = {
+          action = "<Plug>(comment_toggle_linewise_visual)";
+          desc = "toggle the current line in a linewise comment";
+        };
+        "gbc" = {
+          action = "<Plug>(comment_toggle_blockwise_visual)";
+          desc = "toggle the current line in a blockwise comment";
+        };
+      };
+      normal = {
+        "gcc" = {
+          action = "<Plug>(comment_toggle_linewise_current)";
+          desc = "toggle the current line in a linewise comment";
+        };
+        "gbc" = {
+          action = "<Plug>(comment_toggle_blockwise_current)";
+          desc = "toggle the current line in a blockwise comment";
+        };
+      };
+    };
+  };
+}