about summary refs log tree commit diff stats
path: root/hm/soispha/conf/nvim/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
committerSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
commit3f600ab07dbad3b6dd7655587ddea158b19aea71 (patch)
tree7164ccd965e1d14ade970aeb8eb188b1442a6c91 /hm/soispha/conf/nvim/default.nix
parentStyle(treewide): Format all lua-files makes lua ➛ nix easier (diff)
downloadnixos-config-3f600ab07dbad3b6dd7655587ddea158b19aea71.zip
Refactor(treewide): Abbreviate path names
Diffstat (limited to 'hm/soispha/conf/nvim/default.nix')
-rw-r--r--hm/soispha/conf/nvim/default.nix48
1 files changed, 48 insertions, 0 deletions
diff --git a/hm/soispha/conf/nvim/default.nix b/hm/soispha/conf/nvim/default.nix
new file mode 100644
index 00000000..61467618
--- /dev/null
+++ b/hm/soispha/conf/nvim/default.nix
@@ -0,0 +1,48 @@
+{
+  pkgs,
+  lib,
+  ...
+}: {
+  imports = [
+    ./autocmds
+    ./clipboard
+    ./files
+    ./mappings
+    ./options
+    ./plugins
+  ];
+  programs.nixvim = {
+    enable = true;
+
+    # source: https://www.patorjk.com/software/taag/#p=display&f=ANSI%20Shadow&t=Neovim
+    extraConfigLuaPre = lib.mkBefore ''
+      ---------------------------------------------------------------------------
+      --
+      --     ███╗   ██╗███████╗ ██████╗ ██╗   ██╗██╗███╗   ███╗
+      --     ████╗  ██║██╔════╝██╔═══██╗██║   ██║██║████╗ ████║
+      --     ██╔██╗ ██║█████╗  ██║   ██║██║   ██║██║██╔████╔██║
+      --     ██║╚██╗██║██╔══╝  ██║   ██║╚██╗ ██╔╝██║██║╚██╔╝██║
+      --     ██║ ╚████║███████╗╚██████╔╝ ╚████╔╝ ██║██║ ╚═╝ ██║
+      --     ╚═╝  ╚═══╝╚══════╝ ╚═════╝   ╚═══╝  ╚═╝╚═╝     ╚═╝
+      --
+      ---------------------------------------------------------------------------
+    '';
+
+    extraPackages = with pkgs; [
+      /*
+      These are mostly linters and formatters used for different file types.
+      Including them here is fine, as they are not necessarily sync able to different people.
+      */
+      # nix
+      alejandra
+      statix
+
+      # yaml
+      yamllint
+
+      # shell
+      shellcheck
+      shfmt
+    ];
+  };
+}