about summary refs log tree commit diff stats
path: root/hm/soispha/conf/mail/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
committerSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
commit3f600ab07dbad3b6dd7655587ddea158b19aea71 (patch)
tree7164ccd965e1d14ade970aeb8eb188b1442a6c91 /hm/soispha/conf/mail/default.nix
parentStyle(treewide): Format all lua-files makes lua ➛ nix easier (diff)
downloadnixos-config-3f600ab07dbad3b6dd7655587ddea158b19aea71.zip
Refactor(treewide): Abbreviate path names
Diffstat (limited to 'hm/soispha/conf/mail/default.nix')
-rw-r--r--hm/soispha/conf/mail/default.nix64
1 files changed, 64 insertions, 0 deletions
diff --git a/hm/soispha/conf/mail/default.nix b/hm/soispha/conf/mail/default.nix
new file mode 100644
index 00000000..475bcacf
--- /dev/null
+++ b/hm/soispha/conf/mail/default.nix
@@ -0,0 +1,64 @@
+{
+  config,
+  pkgs,
+  lib,
+  ...
+}: let
+  non_public_accounts = import ./non_public_accounts.nix {inherit pkgs;};
+  accounts = lib.recursiveUpdate {inherit soispha;} non_public_accounts;
+
+  soispha = {
+    address = "soispha@vhack.eu";
+    userName = "soispha@vhack.eu";
+    realName = "Soispha";
+    primary = true;
+    passwordCommand = "${pkgs.libsecret}/bin/secret-tool lookup account soispha@vhack.eu";
+    aliases = [
+      "admin@vhack.eu"
+    ];
+    folders = {
+    };
+    gpg = {
+      encryptByDefault = true;
+      key = "9606FC749FCE16360723D4ADA5E94010C3A642AD";
+      signByDefault = true;
+    };
+    signature = {
+      # TODO:
+    };
+    neomutt = {
+      enable = true;
+    };
+    mbsync = {
+      enable = true;
+      create = "both";
+    };
+    himalaya = {
+      enable = true;
+      backend = "imap";
+      sender = "smtp";
+      settings = {
+        # TODO:
+      };
+    };
+    smtp = {
+      host = "server1.vhack.eu";
+      port = 465;
+    };
+    imap = {
+      host = "server1.vhack.eu";
+      port = 993;
+    };
+    jmap = {
+      # TODO:
+    };
+    maildir = {
+      path = "soispha";
+    };
+  };
+in {
+  accounts.email = {
+    maildirBasePath = "${config.xdg.dataHome}/maildir";
+    inherit accounts;
+  };
+}