about summary refs log tree commit diff stats
path: root/hm/soispha/conf/less/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2024-01-21 20:48:31 +0100
committerSoispha <soispha@vhack.eu>2024-01-21 20:51:38 +0100
commitaf48ecac167b64f162e034467048744f1a2b0303 (patch)
treeefe7fe06830c4b4938faf9b573d2412b4fc126cf /hm/soispha/conf/less/default.nix
parentfix(hm/conf/less): Correctly export less variables (diff)
downloadnixos-config-af48ecac167b64f162e034467048744f1a2b0303.zip
fix(hm/conf/less): Ensure that less can read the lesskey file
Diffstat (limited to 'hm/soispha/conf/less/default.nix')
-rw-r--r--hm/soispha/conf/less/default.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/hm/soispha/conf/less/default.nix b/hm/soispha/conf/less/default.nix
index 1d598995..f4103080 100644
--- a/hm/soispha/conf/less/default.nix
+++ b/hm/soispha/conf/less/default.nix
@@ -2,16 +2,16 @@
   home.sessionVariables = {
     PAGER = "less";
     MANPAGER = "less --color=d+r --color=u+b";
+
+    # These are added here because adding them in the lesskey file somehow doesn't work.
+    LESSHISTSIZE = 10000;
+    LESSHISTFILE = "${config.xdg.dataHome}/less/history";
   };
   programs.less = {
     enable = true;
     keys =
       builtins.readFile ./command.less
       + builtins.readFile ./line-edit.less
-      + builtins.readFile ./env.less
-      # This next line *must* be under the `./env.less` include, as it extends the environment definitions
-      + ''
-        LESSHISTFILE = ${config.xdg.dataHome}/less/history
-      '';
+      + builtins.readFile ./env.less;
   };
 }