about summary refs log tree commit diff stats
path: root/hm/soispha/conf/gpg/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2024-03-23 20:43:06 +0100
committerSoispha <soispha@vhack.eu>2024-03-23 20:43:06 +0100
commit40bdcae54a2dec676993672d8a06a1bc75ec368c (patch)
treeb88ddf83559f4db4e95af7d6bf8493f4d6b52d3a /hm/soispha/conf/gpg/default.nix
parentbuild(treewide): Update (diff)
downloadnixos-config-40bdcae54a2dec676993672d8a06a1bc75ec368c.zip
refactor(treewide): Update to new modules names (and simplify some code)
Diffstat (limited to 'hm/soispha/conf/gpg/default.nix')
-rw-r--r--hm/soispha/conf/gpg/default.nix21
1 files changed, 7 insertions, 14 deletions
diff --git a/hm/soispha/conf/gpg/default.nix b/hm/soispha/conf/gpg/default.nix
index d0cc33a2..60c2ef2a 100644
--- a/hm/soispha/conf/gpg/default.nix
+++ b/hm/soispha/conf/gpg/default.nix
@@ -13,6 +13,7 @@
       onlykey-agent
     ];
   };
+
   settings =
     if nixosConfig.networking.hostName == "isimud"
     then {}
@@ -23,20 +24,12 @@
       default-key = "Soispha <soispha@vhack.eu>";
       # TODO: add more
     };
-  gpg-agent =
-    if nixosConfig.networking.hostName == "isimud"
-    then {
-      enable = true;
-      enableZshIntegration = true;
-      enableScDaemon = true; # smartcards and such things
-      pinentryFlavor = "tty";
-    }
-    else {
-      enable = false;
-      enableZshIntegration = true;
-      enableScDaemon = true; # smartcards and such things
-      pinentryFlavor = "tty";
-    };
+  gpg-agent = {
+    enable = nixosConfig.networking.hostName == "isimud";
+    enableZshIntegration = true;
+    enableScDaemon = true; # smartcards and such things
+    pinentryPackage = pkgs.pinentry-tty;
+  };
 in {
   programs.gpg = {
     enable = true;